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デジタルプログラム調節計DCP31/32用
スマートローダパッケージ　SLP-P30を
ご購入いただき、まことにありがとうござ
います。この取扱説明書には、SLP-P30
を正しくご使用いただくための必要事項が
記載されております。
DCP31/32を使用した装置の設計や設定、
保守などを担当される方は、必ずお読みに
なり、理解したうえでご使用ください。
また、この取扱説明書は、初期設定時だけ
でなく、設定値の変更やトラブル時の対応
などの際にも必要です。いつもお手元にお
いてご活用ください。

No. CP-UM-1759JE



この取扱説明書は、本製品をお使いになる担当者のお手元に確実に届
くようお取りはからいください。

この取扱説明書の全部、または一部を無断で複写、または転載するこ
とを禁じます。この取扱説明書の内容を将来予告なしに変更すること
があります。

この取扱説明書の内容については、万全を期しておりますが、万一ご
不審な点や記入もれなどがありましたら、当社までお申し出ください。

お客様が運用された結果につきましては、責任を負いかねる場合がご
ざいますので、ご了承ください。

本製品は、一般機器での使用を前提に、開発・設計・製造されております。
とくに、下記のような安全性が必要とされる用途に使用する場合は、フェールセー
フ設計、冗長設計および定期点検の実施など、システム・機器全体の安全に配慮
していただいた上でご使用ください。

・人体保護を目的とした安全装置
・輸送機器の直接制御（走行停止など）
・航空機
・宇宙機器
・原子力機器　　など

本製品の働きが直接人命に関る用途には使用しないでください。

使用上の制限について

お願い

デジトロニック
TM
は、株式会社山武の商標です。

1996 Yamatake Corporation ALL RIGHTS RESERVED

ローダプラグを接続中は、強い力を加えないでください。計器を破損す
る恐れがあります。

取扱い上の注意
ローダプラグに力を加えすぎると、通信ができなくなることがありま
す。このときは、再度ローダプラグを接続し直してください。

重要事項



確認してください

J-i

お買上げいただいたSLP-P30は、次のように構成されています。
商品の開梱時に次の点について確認してください。

1. ご注文の商品に間違いがないか、形番をチェックする
2. 商品に破損がないかどうか、外観をチェックする
3. 付属品が規定どおりあるか、チェックする

付属品は、次のとおりです。
開梱後は、付属品を紛失したり破損したりしないように、十分注意して取り扱ってください。
万一、異常や間違いがあった場合は、直ちにお買上げの販売店までご連絡ください。

品　名 形　番 数量 備　考

システムディスク SLP-P30J20 1 フロッピーディスク
3.5型　1.44Mバイト

専用ケーブル一式 ー 1 ー

取扱説明書 CP-UM-1759JE 1 本書です
和英合本となっています

お客様登録カード ー 1 お客様登録カードに必要事
項を記入し、直ちにご返送
ください
登録をすると、バージョン
アップのお知らせや問い合
わせに対するサポートが受
けられます

取扱説明
書

株式会
社山武

CP-UM
-0123



この取扱説明書の位置づけ
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DCP31/32関連の取扱説明書は全部で5冊あります。用途に応じて必要な取扱説明書をお読みください。
必要な取扱説明書がお手元にないときは当社、または販売特約店の担当者にお申し付けください。

取扱説明
書

株式会
社山武

CP-UM
-0123

取扱説明
書

株式会
社山武

CP-UM
-0123

デジトロニック　デジタルプログラム調節計　DCP31 取扱説明書
資料番号CP-UM-1757

DCP31(1ループモデル)本体に付属します。
DCP31を使用した装置の設計、製作、保守を担当される方、およびその装
置を使用していろいろなものを処理される方は必ずお読みください。
盤などへの取付け、結線、パラメータ設定、プログラム設定、運転操作の
方法と、保守点検、トラブルシューティング、仕様について説明していま
す。

デジトロニック　デジタルプログラム調節計　DCP31/32用
スマートローダパッケージ　SLP-P30 取扱説明書

資料番号CP-UM-1759JE

本書です。和英合本となっています
SLP-P30のシステムディスクに同梱されています。
パソコン上でSLP-P30を動作させると、パソコンからDCP31/32のパラメ
ータが設定できます。
パソコンの操作を説明しています。

デジトロニック　CPL通信　取扱説明書　DCP31/32編
資料番号CP-UM-1760

DCP31/32のCPL通信機能を使用される方は必ずお読みください。
CPL通信の概要、結線、通信手順とDCP31/32の通信データ一覧、トラブ
ル時の対処、および通信仕様を説明しています。

取扱説明
書

株式会
社山武

CP-UM
-0123 デジトロニック　デジタルプログラム調節計　DCP32 取扱説明書

資料番号CP-UM-5092

DCP32(2ループモデル)本体に付属します。
DCP32を使用した装置の設計、製作、保守を担当される方、およびその装
置を使用していろいろなものを処理される方は必ずお読みください。
盤などへの取付け、結線、パラメータ設定、プログラム設定、運転操作の
方法と、保守点検、トラブルシューティング、仕様について説明していま
す。

取扱説明
書

株式会
社山武

CP-UM
-0123

取扱説明
書

株式会
社山武

CP-UM
-0123 デジトロニック デジタルプログラム調節計 DCP31  キー操作マニュアル

資料番号CP-SP-1030

DCP31のプログラム設定に関するキー操作、設定したプログラムの運転・
停止に関するキー操作の詳細について説明しています。



この取扱説明書の構成
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この取扱説明書は、次のように構成されています。

第1章 ご使用の前に
本ソフトウエアをお使いになる前に一通りお読みください。
動作に必要なパソコンなどの環境、機能の概要を説明しています。

第2章 インストール方法と基本機能
本ソフトウエアのインストール方法、起動・終了方法、機能、画面構成な
ど基本動作について説明しています。

第3章 操作方法
本ソフトウエアの形番、環境、ファイル、データなどの設定方法や、キー
操作について説明しています。

第4章 トラブルシューティング
本ソフトウエア使用時のトラブル時の対策について説明しています。

この取扱説明書の表記について

この取扱説明書の表記は、次のようにしています。

取扱い上の注意 : 取り扱い上、注意していただきたい事柄を示しています。

参考 : 知っていただくと便利な事柄を示しています。

: 参照していただきたい項目およびページを示しています。

①②③ : 操作の手順、または図などの説明のため対応する部分を示しています。

[OK]ボタン : パソコン画面の選択ボタンを示しています。

[ファイル] : パソコン画面のメッセージ、およびメニューを示しています。

[ファイル] → [初期化(N)] : パソコン画面の[ファイル]を選択し、次に[初期化(N)]を選択することを
示しています。

》 : 操作の結果、パソコンや機器に表示される内容や、操作後の機器の状
態を示します。

[Ctrl]キー、[a]キー : キーボードのキーを示しています。

[Ctrl]＋[a]キー : キーボードの[Ctrl]キーを押しながら[a]キーを押すことを示していま
す。
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スマートローダパッケージ　SLP-P30(以下、ローダと呼びます)は、デジトロニック　デジタルプログ
ラム調節計 DCP31/32(以下、本体と呼びます)用のエンジニアリングツールです。
本ローダは、パソコンの日本語版Windows95/98/Me/2000/XP(以下、Windowsと呼びます)上で動作す
るソフトウエアパッケージです。
本ローダは次のような機能を持っています。

① プログラムパターン、パラメータの設定
② 本体との通信機能(プログラムパターン、パラメータの書き込み/読み出し)
③ ファイル機能(プログラムパターン、パラメータの書き込み/読み出し)

第 1 章 ご使用の前に
1  -  1 概　要

J1



1  -  2 動作に必要なシステム環境
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本ローダを使用するには、次のシステム環境が必要です。

■ ハードウェア機器

* : シリアルポートについて
パソコンは9ピンシリアルポートが内蔵されているものを使用するこ
とをお勧めします。
パソコンにシリアルポートが内蔵されていない場合、下記のどれかの
拡張アダプタによりローダケーブルを接続することができます。
ただし、パソコンの環境などにより動作が不安定になることがありま
す。

・専用インターフェイス(ポートリプリケータ)
各パソコン専用アダプタ(パソコンの機種ごとに専用です)

・CFカードアダプタ
IBSジャパン社製CF232
http://www.ibsjapan.com/CF232.htm
動作確認パソコンIBM社ThinkPad A31
RATOC社製REX-CF60
http://www.ratocsystems.com/products/subpage/cf60.html

・USBアダプタ
株式会社アイ・オー・データ機器製USB-RSAQ3
http://www.iodata.jp/prod/mobile/serial/2004/usb-rsaq3/
動作確認パソコンIBM社ThinkPad A31
USBケーブルを接続するときには、ポート番号を確認してください。
USBケーブルを接続する位置によって番号が変わります。

項　目 内　容

パソコン 対象機種 Pentium以上のCPUを搭載しているPC/AT互換機

メモリ 32MB以上

オペレーティングシステム 日本語版Windows95/98/Me/2000/XP

日本語入力システム Windowsに対応した日本語入力システム

周辺機器 ディスプレイ コンピュータ本体に接続可能または内蔵されてい
てWindowsに対応したもの

シリアルポート * 9ピン　シリアルポート　1ch以上

ハードディスクドライブ 空き容量が40MB以上あるハードディスク

フロッピーディスクドライブ 1ドライブ以上
お買い上げいただいたパッケージのフロッピーデ
ィスクを読みとれるタイプのもの
(1.44MBフォーマット)

ポインティングデバイス マウス、またはマウス相当のデバイスでWindows
に対応したもの



取扱い上の注意
・ローダを起動させるときは、他のアプリケーションソフトはすべて終了
してください。
他のアプリケーションソフトが動作中のときは、ローダが動作しないこ
とがあります。

・PC/AT互換機は、ほとんどの機種で動作するように設計されています。

・Windowsのパワーマネージメントが動作していて、長時間RS-232C通
信で接続していると、通信タイムアウトが発生することがあります。
この場合にはパワーマネージメントをOFF(コントロールパネルのパワ
ーマネージメントの設定)にしてください。

■ ハードウェア構成

■ 動作確認に使用したパソコン

SLP-P30

読み出し/保存�

データ用�
ディスク�

送信/受信�

専用ケーブル(付属品)

DCP31/32

J3

メーカー 形　番

Dell OptiPlex G1
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■ インストールの方法
本ローダはパソコンのハードディスクにインストールしてください。
インストールしたあと、システムディスクはバックアップ用として保存し
てください。
ここでは、ローダをパソコンにインストールする方法を説明します。

取扱い上の注意
・このディスクは、パソコンのOSを含まないため、そのままでは使用で
きません。

・他のアプリケーションソフトが動作している場合、インストールプログ
ラムが正常に動作しないことがあります。
他のアプリケーションソフトを終了してからインストールプログラムを
起動してください。
また他のアプリケーション、ドライバなどの組み合わせによりローダが
動作しないことがあります。
Windows、パソコンの設定に関してはそれぞれWindows、パソコンに付
属の取扱説明書をご覧ください。

● ローダをインストールする
①画面下部の[スタート]ボタンをクリック後、[ファイル名を指定して実行]
を選択してください。

②ローダのディスクをフロッピーディスクドライブにセットし、
[A:¥SETUP] を入力し、[Enter]キーを押してください。
》インストールプログラムが起動されます。

第 2 章 インストール方法と基本機能
2  -  1 インストール方法と起動・終了
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③ [Japanese(日本語)] を選択し、[OK]ボタンをクリックしてください。
》次の画面が表示されます。

④ [次へ(N)＞]ボタンをクリックしてください。
》次の画面が表示されます。
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⑤ソフトウエア使用権許諾契約に同意し、インストールをする場合は、
[同意する]ボタンをクリックしてください。
インストールを中止する場合は、[同意しない]ボタンをクリックしてく
ださい。
》[同意する]ボタンをクリックすると、次の画面が表示されます。

参考
・インストール先ディレクトリを変更するには [参照(B)...]ボタンを
クリックしてください。

⑥ [次へ(N)＞]ボタンをクリックしてください。
》次の画面が表示されます。

参考
・グループを変更する場合は、グループ名を入力してください。
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⑦ [次へ(N)＞]ボタンをクリックしてください。
》次の画面が表示されます。

⑧ [次へ(N)＞]ボタンをクリックしてください。
》次の画面が表示されます。

⑨ [完了(F)]ボタンをクリックしてください。
》正常終了すると、Windowsに戻ります。
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■ ローダを起動する

取扱い上の注意
・ローダを起動させるときは、他のアプリケーションソフトはすべて終了
してください。
他のアプリケーションソフトが動作中のときは、ローダが動作しないこ
とがあります。

・[コントロールパネル] → [地域] → [数値] → [小数点の記号] は必ず「.」
に設定されていることを確認してください。他の文字に設定されている
とローダは正常に動作しません。

①画面下部の[スタート]ボタンをクリックし、
[プログラム] → [SLP] → [SLP-P30(DCP31,32)] を選択してください。
》ローダは起動し、基本画面とその上に取扱い上の注意が表示されます。

② [次へ(N)＞]ボタンをクリックしてください。
》形番設定方法の画面が表示されます。
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③形番設定方法の画面よりどちらかを選択し、[次へ(N)＞]ボタンをクリッ
クしてください。
》[0:形番を設定する] を選択した場合は、
基本形番画面が表示されます。
[1:設定をDCP30から読み出す] を選択した場合は、
通信範囲の選択画面が表示されます。

操作方法の詳細については、
基本形番画面が表示の場合　　　 : 3-1  形番設定と環境設定 (J13ページ)
通信範囲の選択画面が表示の場合 : 3-3  本体との通信 (J18ページ)
をご覧ください。

参考
・使用しているオペレーティングシステムやマウスの使用方法につい
ては、Windowsに付属の取扱説明書をご覧ください。

■ ローダを終了する
①画面右上の アイコンをクリックしてください。
また、[メニュー] → [終了] を選択しても同じ処理が行えます。
》次の画面が表示されます。

② [OK]ボタンをクリックしてください。



2  -  2 機能説明
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■ ローダの機能
ローダは本体の機能を構築するのに必要な
・プログラムパターン編集機能
・パラメータ編集機能
・ファイル管理機能
・データの通信機能
・形番設定機能
を持っています。
機能の一覧は次のとおりです。

参考
・1ファイルとは本体1台分のデータのことです。
1ファイル=各パラメータ設定＋形番情報

機　能�

プログラムパターン編集機能�

パラメータ編集機能�

ファイル管理機能�

・プログラムパターンを作成/編集する�
�
�
�
・各パラメータを作成/編集する�
�
�
・作成したデータをフロッピーディスク�
　ハードディスクにファイルとして保存する�
・保存したファイルの読み出し、再編集する�
�
�
・作成したデータを本体へ書き込む�
・本体からローダへ読み出す�
�
�
�
・ローダと接続する本体形番を設定する�

データ通信機能�

形番設定機能�

�



■ ローダの画面構成
・ローダの基本画面です。

・[ヘルプ] → [バージョン情報] を選択したときのダイアログボックス表
示です。

タグ�

パターン番号�

設定項目�

メッセージウインドウ�

メニューバー�

ツールバー�

選択ウインドウ�

2  -  3 画面構成

J11
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2  -  4 メニュー構成一覧

取扱い上の注意
・セグメント切り取りを行うと、コピーしたセグメント(C)は切り取った
セグメント(C)になります。
また、セグメントコピーを行うとセグメントコピー(C)に戻ります。

メニュー アイコン サブメニュー1 サブメニュー2 内　容 ショートカットキー

ファイル(F) 初期化(N) - データを出荷時設定に初期化 [Ctrl]＋[n]

開く(O) - 保存してあるファイルを読み出す [Ctrl]＋[o]

上書き保存(S) - データを保存 [Ctrl]＋[s]

名前を付けて保存(A) - データを別の名前で保存 [Ctrl]＋[a]

- CSV出力(X) - データをCSV形式でファイル出力 -
- HTML出力(H) - データをHTML形式でファイル出力 -
- 終了(Q) - 終了 [Ctrl]＋[q]

編集(E) - データチェック(D) - データの上下限チェック -
セグメント挿入(I) 新しいセグメント(N) 新しいセグメントデータを挿入 -

- コピーした 記憶されたセグメントデータを挿入 -
セグメント(C)

セグメント切り取り(T) - 選択されているセグメントデータを [Ctrl]+[x]
記憶し、そのセグメントデータを削除

セグメントコピー(C) - 選択されているセグメントデータを [Ctrl]+[c]
記憶

セグメント貼り付け(P) - 記憶したセグメントデータを選択 [Ctrl]+[v]
されているセグメントに上書き

クリア(A) - 選択されているデータを初期化 -

パターンコピー(Y) - 選択されているパターンデータを -
記憶

パターン貼り付け(S) - 記憶したパターンデータを選択され -
ているパターンに上書き

通信(C) 読出し(R) - 本体のデータを読み出す [Ctrl]＋[r]
(DCP30→SLP)
書込み(W) - データを本体に書き込む [Ctrl]＋[w]
(SLP→DCP30)

項目(S) - プログラム設定(A) プログラム設定(A) プログラム設定の表示 [Ctrl]+[Shift]+[a]
- パラメータ設定(B) 可変パラメータ(B) 可変パラメータの表示 [Ctrl]+[Shift]+[b]

可変パラメータ2(C) 可変パラメータ2の表示 [Ctrl]+[Shift]+[c]
イベントコンフデータ(D) イベントコンフデータの表示 [Ctrl]+[Shift]+[d]
PIDパラメータ(E) PIDパラメータの表示 [Ctrl]+[Shift]+[e]
PIDパラメータ2(F) PIDパラメータ2の表示 [Ctrl]+[Shift]+[f]
セットアップデータ(G) セットアップデータの表示 [Ctrl]+[Shift]+[g]
テーブルデータ(H) テーブルデータの表示 [Ctrl]+[Shift]+[h]
定値運転データ(I) 定値運転データの表示 [Ctrl]+[Shift]+[ i ]

設定(O) 形番設定(T) - 形番設定の変更 [Ctrl]＋[t]

環境設定(E) - 動作環境の変更 [Ctrl]＋[e]

表示(V) - パターングラフ(P) - パターングラフの表示 -
- 折線グラフ(T) - 折線グラフの表示 -

ヘルプ(H) - バージョン情報(V) - バージョン情報を表示 -
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第 3 章 操作方法
3  -  1 形番設定と環境設定

■ 形番設定
最初に本体の形番にあわせてローダの形番設定を行ってください。

① アイコンをクリックしてください。
[設定] → [形番設定] を選択しても同じ処理ができます。
また、[Ctrl]＋[t]キーでも同じ処理ができます。
》形番設定ダイアログボックスが表示されます。

②基本形番を設定し、[次へ(N)＞]ボタンをクリックしてください。
》出力形式の画面が表示されます。
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③出力形式を設定し、[次へ(N)＞]ボタンをクリックしてください。
》オプション1の画面が表示されます。

④オプション1を設定し、[次へ(N)＞]ボタンをクリックしてください。
》オプション2の画面が表示されます。

⑤オプション2を設定し、[ 完了]ボタンをクリックしてください。

取扱い上の注意

・ここで設定する形番は、ローダの内部で使用するためのものです。
正しい本体形番を設定してください。
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■ 環境設定
パソコンの通信ポートの切り替えとフォントの切り替えを設定します。

① アイコンをクリックしてください。
[設定] → [環境設定] を選択しても同じ処理ができます。
また、[Ctrl]＋[e]キーでも同じ処理ができます。
》環境設定ダイアログボックスが表示されます。

②通信ポートを設定します。各設定を選択してください。

③フォントの大きさを設定します。各設定を選択してください。

④ [ OK]ボタンをクリックしてください。

取扱い上の注意

・通常は「ポートCOM1」を使用してください。
選択可能な場合でも通信ポートのコネクタの形状により使用できな
いことがあります。
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■ 新規ファイルを作成する
① アイコンをクリックしてください。

[ファイル] → [初期化] を選択しても同じ処理ができます。
また、[Ctrl]＋[n]キーでも同じ処理ができます。
》初期化ダイアログボックスが表示されます。

② [OK]ボタンを選択してください。
》新規のファイルが開きます。

■ 既存のファイルを開く
① アイコンをクリックしてください。

[ファイル] → [開く] を選択しても同じ処理ができます。
また、[Ctrl]＋[o]キーでも同じ処理ができます。
》ファイルを開くダイアログボックスが表示されます。

② [ファイルの場所] でフォルダ名を選択してください。

③ファイル名を選択してください。

④ [開く(O)]ボタンをクリックしてください。
》設定したファイル名のファイルが開きます。

■ ファイルを上書き保存する
① アイコンをクリックしてください。

[ファイル] → [上書き保存] を選択しても同じ処理ができます。
また、[Ctrl]＋[s]キーでも同じ処理ができます。
》ファイルが上書き保存されます。

3  -  2 ファイルの操作
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■ ファイルに名前を付けて保存する
① アイコンをクリックしてください。

[ファイル] → [ファイルに名前を付けて保存] を選択しても同じ処理が
できます。
また、[Ctrl]＋[a]キーでも同じ処理ができます。
》名前を付けて保存ダイアログボックスが表示されます。

② [保存する場所] でフォルダ名を選択してください。

③ [ファイル名] にファイル名を入力してください。

④ [保存]ボタンをクリックしてください。
》設定したファイル名でファイルが保存されます。

参考
・ファイル名ウインドウでファイル名をクリック選択したときは、上
書き保存となります。

■ CSV形式ファイルを出力する
① [ファイル] → [CSV出力] を選択してください。
また、[Ctrl]＋[x]キーでも同じ処理ができます。
》CSV出力ダイアログボックスが表示されます。

② [保存する場所] でフォルダ名を選択してください。

③ [ファイル名] でファイル名を入力してください。

④ [保存]ボタンをクリックしてください。
》設定したファイル名でファイルが出力されます。

参考
・ファイル名ウインドウでファイル名を選択したときは、上書き保存
となります。
CSV形式はカンマで区切られたテキストファイルです。
市販の表計算ソフトMicrosoft Excelなどで利用できます。

・Microsoft ExcelでCSV形式のファイルを開いた場合、数値、時間な
どの表示形式はMicrosoft Excelの標準形式に変換されます。

■ HTML形式ファイルを出力する
① [ファイル] → [HTML出力] を選択してください。
》HTML出力ダイアログボックスが表示されます。

② [保存する場所] でフォルダ名を選択してください。

③ [ファイル名] でファイル名を入力してください。

④ [保存]ボタンをクリックしてください。
》設定したファイル名でファイルが出力されます。

参考
・ファイル名ウインドウでファイル名を選択したときは、上書き保存
となります。

・HTML形式はブラウザソフトMicrosoft Internet Explorer、ワードプ
ロセッサMicrosoft Wordなどで利用できます。
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■ 本体のデータを読み出す(ローダへ読み出す)
① アイコンをクリックしてください。

[通信] → [読出し(DCP30→SLP)] を選択しても同じ処理ができます。
また、[Ctrl]＋[r]キーでも同じ処理ができます。
》確認ダイアログボックスが表示されます。

②通信内容を選択し、[ OK]ボタンをクリックしてください。
》確認ダイアログボックスが表示されます。

③ [ OK]ボタンをクリックしてください。
》ローダへの読み出しを開始します。

■ データを本体に書き込む(ローダから書き込む)
① アイコンをクリックしてください。

[通信] → [書込み(SLP→DCP30)] を選択しても同じ処理ができます。
また、[Ctrl]＋[w]キーでも同じ処理ができます。
》通信ダイアログボックスが表示されます。

②通信内容を選択し、[ OK]ボタンをクリックしてください。
》確認ダイアログボックスが表示されます。

③ [ OK]ボタンをクリックしてください。
》本体への書き込みを開始します。

取扱い上の注意
・データに設定異常があると、エラーリストを表示し、通信は行われませ
ん。

・本体とローダで設定した形番があっていない場合、形番が異なっている
ことを表示します。

3  -  3 本体との通信
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3  -  4 データの設定

■ 設定項目を選択する

● キーボードで反転表示を移動する
① [→]、[←]、[↑]、[↓]キーを押すと表の中で反転表示が移動します。

● マウスで反転表示を移動する
①移動したい部分でクリックしてください。

②スクロールバーをクリックしてください。
》画面がスクロールします。最上段、最下段が表示されているときはそ
れ以上スクロールしません。

● 操作するウインドウを変更する
① [Tab]キーを押してください。
》操作対象のウインドウが移動します。

参考
・設定できる部分を順番に移動します。

■ 数値データを入力する

● 数値の入力方法
数値の入力方法は次のとおりです。
・数値を入力したいときはキーボードの[0]～[9]キーを押してください。

・16進数を入力したいときはキーボードの[0]～[9]キー、[A]～[F]キーを押
してください。

・小数点を入力したいときは希望の位置で[ . ]キーを押してください。

・マイナス値を入力したいときは[ー]キーを押してください。

・時間データを入力したいときはキーボードの[0]～[9]キー、[:]キー、[.]キ
ーを押します。

参考

・「2:00」と入力したい場合、[2][:][0][0]と入力します。
また、[1][2][0]と入力することもできます。
・「h:min」、「min:s」のとき、[.]キーを使用して設定することはで
きません。また、「0.1s」のとき、[:]キーを使用して設定すること
はできません。

・入力を間違えて、1文字消したいときは[Back Space]キーを押してくだ
さい。
》表示されている値が1文字消えます。

・入力中の数値をキャンセルしたいときは[Esc]キーを押してください。
》元の設定値が表示されます。
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● 設定項目への入力
設定項目への入力は[0]～[9]キーを使用してください。
①設定項目を選択(反転表示)します。

②希望の設定値を[0]～[9]キーにより入力してください。

③ [Enter]キーを押します。また、[↑]、[↓]キーでも同じ処理ができます。
》設定値が確定されます。

参考

・[↑]、[↓]キーの場合、数値確定後に反転表示が移動します。
マウスで設定項目を移動したときは、設定値は確定されません。

・設定値が無効なときは、元の設定値が表示されます。
途中で取り消したいときは、設定値を確定する前に[Esc]キーを押し
てください。

● データを選択して入力する

参考

・選択入力ができる項目では自動的に項目が表示されます。

①設定項目のボタンを押してください。
[Tab]キーで設定項目へ反転表示を移動させた後に、[Alt]＋[↓]キーを押
しても同じ処理ができます。
》選択項目が表示されます。

②マウスで設定を選択してください。
[→]、[←]、[↑]、[↓]キーで選択したい項目へ反転表示を移動させた後
に、[Enter]キーでも同じ処理ができます。
》設定値が確定されます。

参考

・マウスを使用する場合、クリックで選択と決定が同時に行われます。

設定項目� 設定項目のボタン�



■ セグメントを編集する
セグメントの編集機能を使用するときは、あらかじめ対象のセグメントに
反転表示をあわせておく必要があります。

● 新しいセグメントを挿入する

① アイコンをクリックしてください。
[編集] → [セグメント挿入] → [新しいセグメント] を選択しても同じ処
理が行えます。
》確認ダイアログボックスが表示されます

② [OK]ボタンをクリックしてください。
》新しいセグメントが挿入されます。

● コピーした/切り取ったセグメントを挿入する

① アイコンをクリックしてください。
[編集] → [セグメント挿入] → [コピーした/切り取ったセグメント] を選
択しても同じ処理が行えます。
》確認ダイアログボックスが表示されます。

② [OK]ボタンをクリックしてください。
》コピーした/切り取ったセグメントが挿入されます。

取扱い上の注意

・コピーした/切り取ったセグメントの挿入を行うときは、あらかじめ
セグメントコピー/セグメント切り取りを行っておく必要がありま
す。同じ設定値を何度もコピーした/切り取ったセグメントの挿入に
使用することができます。

● セグメントを切り取る

① アイコンをクリックしてください。
[編集] → [セグメント切り取り] を選択しても同じ処理が行えます。
また、[Ctrl]＋[x]キーでも同じ処理が行えます。
》確認ダイアログボックスが表示されます。

② [OK]ボタンをクリックしてください。
》セグメントが切り取られます。

取扱い上の注意

・切り取られたデータはローダの内部に保持されます。
切り取ったデータを別のセグメントに使用するときは、
●コピーした/切り取ったセグメントを挿入する (前項)
●セグメントを貼り付ける (J22ページ)
をご覧ください。

3  -  5 プログラムパターンの編集

J21
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● セグメントをコピーする

① アイコンをクリックしてください。
[編集] → [セグメントコピー] を選択しても同じ処理が行えます。
また、[Ctrl]＋[c]キーでも同じ処理が行えます。
》確認ダイアログボックスが表示されます。

② [OK]ボタンをクリックしてください。
》セグメントがコピーされます。

取扱い上の注意

・コピーされたデータはローダの内部に保持されます。
コピーしたデータを別のセグメントに使用するときは、
●コピーした/切り取ったセグメントを挿入する (J18ページ)
●セグメントを貼り付ける (次項)
をご覧ください。

● セグメントを貼り付ける

① アイコンをクリックしてください。
[編集] → [セグメント貼り付け] を選択しても同じ処理が行えます。
また、[Ctrl]＋[v]キーでも同じ処理が行えます。
》確認ダイアログボックスが表示されます。

② [OK]ボタンをクリックしてください。
》セグメントが貼り付けられます。

取扱い上の注意

・セグメント貼り付けを行うときは、あらかじめセグメントコピー/セ
グメント切り取りを行っておく必要があります。

・貼り付けたいセグメントに設定値が設定されているときは、上書き
で設定値が貼り付けられます。

・同じ設定値を何度もセグメント貼り付けに使用することができます。

● クリアする

① アイコンをクリックしてください。
[編集] → [クリア] を選択しても同じ処理が行えます。
》確認ダイアログボックスが表示されます。

② [OK]ボタンをクリックしてください。
》設定値がクリアされます。

参考

・クリアは設定値を出荷時の設定に戻すための機能です。

取扱い上の注意

・セットアップデータC68～C71で「プログラム項目を表示しない」
を選択すると、本体のプログラム項目表示はされませんが、SLP-
P30のプログラムパターンウインドウの項目は表示されます。
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■ プログラムパターンを編集する
プログラムパターンの編集機能を使用するときは、あらかじめ対象のプロ
グラムパターンを表示させておく必要があります。

●プログラムパターンをコピーする

① アイコンをクリックしてください。
[編集] → [パターンコピー] を選択しても同じ処理が行えます。
》確認ダイアログボックスが表示されます。

② [OK]ボタンをクリックしてください。
》プログラムパターンがコピーされます。

取扱い上の注意

・コピーされたデータはSLP-P30の内部に保持されます。
コピーしたデータを別のプログラムパターンに使用するときは、
●プログラムパターンを貼り付ける (次項)
をご覧ください。

●プログラムパターンを貼り付ける

① アイコンをクリックしてください。
[編集] → [パターン貼り付け] を選択しても同じ処理が行えます。
》確認ダイアログボックスが表示されます。

② [OK]ボタンをクリックしてください。
》プログラムパターンが貼り付けられます。

取扱い上の注意

・パターン貼り付けを行うときは、あらかじめパターンコピーを行っ
ておく必要があります。
貼り付けたいプログラムパターンに設定値が設定されているときは、
上書きで設定値が貼り付けられます。
同じ設定値を何度もパターン貼り付けに使用することができます。

■ タグを変更する

● タグを変更する

①タグのテキストをダブルクリックしてください。
》タグが反転表示されます

②変更したいタグをキーボードより入力してください。

③ [Enter]キーを押してください。

参考

・不正な文字が挿入されていたときは、元のタグ名に戻ります。
タグに使用できる文字は、アスキー文字コード(20～5FH)の数字、
英大文字、記号です。
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■ アスキーコード表

上位3ビット�

下位4ビット�

 0 1 2 3 4 5 6 7�
0 NUL SLE space 0 @ P ' p�
1 SOH CS1 ! 1 A Q a q�
2 STX DC2 " 2 B R b r�
3 ETX DC3 # 3 C S c s�
4 EOT DC4 $ 4 D T d t�
5 ENQ NAK % 5 E U e u�
6 ACK SYN & 6 F V f v�
7 BEL EIB ' 7 G W g w�
8 BS CAN ( 8 H X h x�
9 HT EM ) 9 I Y i y�
A LF SIB * : J Z j z�
B VT ESC + ; K [ k {�
C FF FS , < L ¥ l ¦�
D CR GS - = M ] m }�
E SO RS . > N ^ n ̃�
F SI US / ? O _ o DEL

(     )の部分は使用しません。�



■ プログラムパターングラフの表示
[表示] → [パターングラフ] を選択してください。
》選択されているプログラムパターンのパターングラフが表示されます。

■ 入力折線グラフの表示
[表示] → [折線グラフ] を選択してください。
》折線グラフが表示されます。

参考

・拡大したい領域を、マウスで左上から右下にドラッグして選択する
と、その領域が拡大表示されます。
反対方向にドラッグすると元のスケールに戻ります。

3  -  6 グラフの表示
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3  -  7 データチェック
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■ 全データの上下限チェックを行う
[編集]→ [データチェック] を選択してください。
》データチェックが行われます。

■ 異常値の項目を表示する
データの上下限チェックで、設定異常が見つかった場合、エラーダイアロ
グボックスが表示され、エラーリストに設定異常の項目がリスト表示され
ます。

①エラーダイアログで[OK]ボタンをクリックしてください。

②エラーリストで表示する設定項目をダブルをクリックしてください。
表示する設定項目を選択(反転表示)し、[Enter]キーを押しても同じ処理
が行えます。
》該当する設定項目が表示されます。

参考

・エラーリストには
「通し番号 : 設定グループ名 :項目名 : 列番号」が表示されます。
また、設定グループがプログラムのときは、設定グループ名が
「プログラム　- プログラム番号」と表示されます。
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第 4 章 トラブルシューティング
4  -  1 エラーメッセージ

■ 通信エラーメッセージ

■ ファイルエラーメッセージ

分　類 メッセージ 内　容 対処方法

通信エラー タイムアウト タイムアウト時間内に電文を受 ケーブルの接続、接触を確認し
信できなかった てください
接続されている計器がDCP31/32 DCP31/32に接続して使用して
以外のものである ください
本体が接続されていない

通信ポートをオープンできま 通信ポートをオープンできなか 他の通信ポートを使用している
せん った ソフトと同時に使用しないでく

ださい

通信エラーが発生しました システムのエラーが発生した 再操作またはローダを終了させ
Windowsを再起動させてくださ
い

本体 コンソールまたはCPL通信で 本体で別の操作が行われている 本体での操作、またはCPL通信
状態エラー 操作中です を終了した後、再度操作を行っ

てください

READY以外の状態のため、 本体がREADY以外の状態に 本体をREADYの状態にしてから
書き込みを行えませんでした なっている 操作を行ってください
READY以外の状態のため、 本体の状態を確認した後、再度
書き込みを行えないデータが 操作を行ってください
ありました
計器の状態により、書き込み
を行えませんでした

接続中の計器を確認してくだ 接続されている計器がDCP31/32 DCP31/32に接続して使用して
さい 以外のものである ください

DCP31/32が接続されていない

接続中のDCP30をサポート 使用しているSLP-P30と 当社支店、営業所、および販売
できません DCP31/32のバージョンが対応 店にご相談ください

していない

分　類 メッセージ 内　容 対処方法

ファイル名 このファイル名は無効です 無効なファイル名を入れた 正しいファイル名を入力してく
エラー ださい

このファイル名が見つかり 存在しないファイル名を入力 存在するファイル名を正しく入
ません した 力してください
パスとファイル名を確認して
ください

このファイル名はデバイス名 デバイス名として予約されてい 正しいファイル名を入力してく
として予約されています るファイル名を入力した ださい
別の名前を指定してください

ディスク ディスクの空き容量が不足で ディスクの空き容量が不足して 新しいディスクを入れてくださ
エラー す いる い

デバイスの準備ができていま ディスクが準備できていない ディスクを準備したあと、再度
せん 操作を行ってください

ファイルを作成できません 保存先がCD-ROMだった 別の場所に保存してください

ファイル名が長すぎます ファイル名が長すぎた ファイル名を255文字以内にし
てください

パス名 パス名が存在しません 不正なパス名を入力した 正しいパス名を入力し、再度操
エラー パス名を確認してください 作を行ってください

ファイル情報 ファイルサイズが不正です ファイルが壊れている 壊れたファイルは使用できません

エラー ファイル情報が不正です 再度、作成してください
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■ 起動エラーメッセージ

分　類 メッセージ 内　容 対処方法

ローダ 一度に複数のSLP-P30を ローダを多重起動した [OK]ボタンを押してください
システム 起動することはできません
エラー



改訂履歴

印刷年月 資料番号 種　類 改訂ページ 改訂内容

04-12 第 5 版 パソコンOS変更のため全面改訂、和英合本とす
る

05-02 第 6 版 J2 USBアダプタ　I/Oデータ社製USB-RSAQ2→
USB-RSAQ3に変更、HPアドレスを変更

05-08 第 7 版 J2、J3 USBアダプタ　I/Oデータ社製→株式会社アイ・
オー・データ機器製に変更
取扱い上の注意を追加

08-01 第 8 版 J11 ・[ヘルプ] → [バージョン情報]  画面変更
08-08 CP-UM-1759JE 第 9 版 資料番号変更
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ちしております。ぜひ、ご協力をお願いします。
ご記入くださいましたら、ご面倒でもFAXにて当社までご送付願います。

機器の使用方法やトラブルの対策などについてのお問い合わせは、購入された販売店、または当社販売
員にお問い合わせください。

名　称 デジトロニック　デジタルプログラム調節計　DCP31/32用　

スマートローダパッケージ　SLP-P30 CP-UM-1759JE 第9版

ページ 行 内容へのご指摘 / ご要望
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回答をご希望の方は、下記に連絡先をご記入ください。
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SLP-P30
Smart Loader Package

for
DCP31/32

DIGITRONIK
Digital Program Controller

User's Manual

No. CP-UM-1759JE

Thank you for purchasing the SLP-P30
for DCP31/32 DIGITRONIK Digital
Program Controller.

This manual contains information for
ensuring correct use of the SLP-P30. It
also provides necessary information for
installation, maintenance, and trou-
bleshooting.

This manual should be read by those
who design and maintain devices that
use the SLP-P30.

Be sure to keep this manual nearby for
handy reference.



This product has been designed, developed and manufactured for general-purpose
application in machinery and equipment.

Accordingly, when used in the applications outlined below, special care should be taken
to implement a fail-safe and/or redundant design concept as well as a periodic
maintenance program.

• Safety devices for plant worker protection
• Start/stop control devices for transportation and material handling machines
• Aeronautical/aerospace machines
• Control devices for nuclear reactors

Never use this product in applications where human safety may be put at risk.

RESTRICTIONS ON USE

The DIGITRONIK
TM

is a trademark of Yamatake Corporation in Japan.

REQUEST

©2004 Yamatake Corporation ALL RIGHTS RESERVED

Ensure that this user's manual is handed over to the user before the
product is used.

Copying or duplicating this user's manual in part or in whole is forbid-
den. The information and specifications in this user's manual are sub-
ject to change without notice.

Considerable effort has been made to ensure that this user's manual is
free from inaccuracies and omissions. If you should find any inaccura-
cies or omissions, please contact Yamatake Corporation.

In no event is Yamatake Corporation liable to anyone for any indirect,
special or consequential damages as a result of using this product.

Do not apply strong force while connecting a loader plug. Doing so might
damage the instrument.

Handling Precautions
Application of excessive force to the loader plug might cause
communication failure. If such failure happens, reconnect the loader
plug correctly.

IMPORTANT



Unpacking

E-i

Check the following items when removing the SLP-P30 from its package:

1. Check the model No. to make sure that you have received the product which you ordered.

2. Check the SLP-P30 for any apparent physical damage.

3. Check the contents of the package against the Package List to make sure that all accessories are included

in the package.

After unpacking, handle the SLP-P30 and its accessories with care to prevent damage or loss of parts.

If an inconsistency is found or the package contents are not in order contact your dealer, immediately.

Name Model No. Q'ty Remarks

System disk SLP-P30J20 1 Floppy disk
3.5 inch disk (1.44MB)

Dedicated cable - 1 -

User's Manual CP-UM-1759JE 1 This manual. This manual is
written in both Japanese and
English.



The Role of This Manual
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The 4 manuals described below are available for the DCP31/32. Read them as necessary for your specific

requirements.

If a manual you require is not available, contact Yamatake Corporation or your dealer.

SLP-P30 Smart Loader Package for DCP31/32 User's Manual
Manual No. CP-UM-1759JE

This manual. This manual is written in both Japanese and English.

This manual is supplied with the Smart Loader Package SLP-P30. The
manual describes the software used to make various settings for the
DCP31/32 using a personal computer.

Personnel in charge of design or configuration of a system using the
DCP31/32 must thoroughly read this manual.

The manual describes software installation, operation of the personal
computer, various functions, and setup procedures.

DCP31/32 DIGITRONIK CPL Communication User's Manual

Manual No. CP-SP-1066E

This manual is required reading for those using the CPL communications
functions of the DCP31/32.

This manual outlines CPL communications, wiring, communications
procedures and DCP31/32 communications data, troublesheeting, and
communications specifications.

DCP31 DIGITRONIK Digital Program Controller User's Manual

Manual No. CP-UM-1757E

This manual is provided with the DCP31 (single-loop model). It is required
reading for those in charge of designing, producing and maintaining control
systems incorporating the DCP31, and for those using the DCP31 in other
applications.

It describes mounting onto control panels, wiring, parameter setup,
program setup, operation methods, maintenance and inspection,
troubleshooting and specifications.

DCP32 DIGITRONIK Digital Program Controller User's Manual

Manual No. CP-SP-1042E

This manual is provided with the DCP32 (double-loop model). It is required
reading for those in charge of designing, producing and maintaining control
systems incorporating the DCP32, and for those using the DCP32 in other
applications.

It describes mounting onto control panels, wiring, parameter setup,
program setup, operation methods, maintenance and inspection,
troubleshooting and specifications.



Organization of This User's Manual
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This manual is organized as follows:

Chapter 1. INTRODUCTION
Be sure to read this chapter before you start using the Smart Loader Package. The chapter describes
the required operating environment for the personal computer and briefly introduces the features of
the Smart Loader Package.

Chapter 2. INSTALLATION AND BASIC OPERATION
This chapter describes how to install, start and quit the SLP-P30, and summarizes its functions,
screen configurations and basic operations.

Chapter 3. METHODS OF OPERATION
This chapter describes setup operations for environment, file operations, communications with the
DCP31/32 and data.

Chapter 4. TROUBLESHOOTING
This chapter describes error messages and remedies for problems that may occur.

Conventions Used in This Manual

The following conventions are used in this manual:

Handling Precautions:
Handling Precautions indicate items that the user should pay attention to when
handling the SLP-P30.

Note: Notes indicate useful information that the user might benefit by knowing.

: This indicates the item or page that the user is requested to refer to.

(1), (2), (3): The numbers within the parentheses indicate steps in a sequence or indicate
corresponding parts in an explanation.

[OK] button: Indicates a selection button on a personal computer screen.

[File]: Indicates messages and menus displayed on the personal computer.

[File] → [New]:
Indicates a sequence of selections on a personal computer. Select [File] first
and then select [New].

>>: Indicates the result of an operation, details displayed on the personal computer
or other devices, or the state of a device after an operation.

[Ctrl] key: Indicates keys on the keyboard.
[x] key

[Ctrl]+[x] keys: Indicates the operation of pressing the [x] key with the [Ctrl] key on the keyboard
held down.
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Chapter 1. INTRODUCTION
1  -  1 Overview

The SLP-P30 (simply called “SLP” from here on) is an engineering tool for the DIGITRONIK Digital Program

Controller DCP31/32 (simply called “DCP” from here on).

The SLP runs on Windows98/Me/2000/XP (simply called “Windows” from here on) on a personal computer.

The SLP has the following functions:

(1) Program pattern editing and parameter editing

(2) Data communication (program patterns, writing/reading of parameters)

(3) File management (program patterns, writing/reading of parameters)
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1  -  2 System Operating Environment

The following system environment is required for using the loader:

� Hardware

* : Serial port

It is recommended to use a personal computer with 9-pin serial port built-in.

If your personal computer does not have any serial port, you may use any of

the extension adaptors listed below to connect the loader cable.

However, note that the operation may become unstable depending on the

personal computer environment.

• Special interface (port replicater)
Adaptor specially designed for each personal computer (special adaptor for

each personal computer model)

• CF card adaptor
CF232 manufactured by Elan Digital systems

URL: http://www.elandigitalsystems.com/interface/cf232.php

Operation confirmed personal computer, IBM's Thinkpad A31

REX-CF60 manufacture by RATOC.

URL: http://www.ratocsystems.com/products/subpage/cf60.html(Japanese)

• USB adaptor
USB-RSAQ3 manufactured by I•O DATA DEVCE, INC.

URL: http://www.iodata.jp/prod/mobile/serial/2004/usb-rsaq3/(Japanese)

Operation confirmed personal computer, IBM's Thinkpad A31

When connecting the USB cable, check the port No.

The port No. may vary depending on the USB cable connection position.

Handling Precautions
• Before starting up SLP-SE6, quit all other applications.

If you start up SLP-SE6 while another application is running, SLP-SE6
may malfunction.

• This loader is so designed that it runs on almost all the PC/AT
compatibles.

• The communication time-out may occur if the loader is connected
through the RS-232C communication for an extended period of time
while Windows’ power management is running.
In this case, turn OFF the power management (power management
setting of Control Panel).

Item Description

Personal Computer Target model PC/AT compatibles with a Pentium chip or higher

Memory 32 MB or more

Operating system Windows98/Me/2000/XP

Peripheral Devices Display 800 x 600 pixels or more, 16-bit color or more

Serial port* 9-pin serial port, 1 channel or more

Hard disk drive Hard disk with at least 40 MB of free space

Floppy disk drive At least 1 drive capable of reading the floppy disk
in the product package (1.44MB format)

Pointing device Windows-compatible mouse or equivalent device
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� Hardware configuration

� Personal computer used for confirmation of operating environment

SLP-P30

Reading/Saving
Data disk

Communications
Special Cable (Accessory)

DCP31/32

Manufacturer Model No.

Dell OptiPlex G1



Chapter 2. INSTALLATION AND BASIC OPERATION
2  -  1 Installation, Starting and Quitting the Software Package

E4

� Installation
Install the SLP on the hard disk of a personal computer.

Keep the system disk that you purchased as a backup.

This section describes how to install the SLP on a personal computer.

Handling Precautions
• This disk does not contain the PC operating system, and you cannot use

it without an operating system.

• The installation program may maIfunction if you start it while another
application is running. Close resident applications before starting up the
installation program. The SLP sometimes cannot be started depending
on the combination of other applications and drivers.

For details on Windows and personal computer settings, refer to their
user’s manuals.

� Installing the SLP
(1) Click the [Start] button at the bottom of the screen, and then click [Run...].
(2) Enter “A:\setup” (without the quotes).

(3) Insert the disk provided with the software package into the disk drive, and click

the [OK] button.

>>The installation program is then started up automatically and the following

screen appears:
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(4) Click the [Next >] button.

>>The following screen appears:

(5) If you agree to the software license agreement and wish to install the loader,

click the [Next >] button. If you want to abort the installation, click the

[Cancel] button.

>>After clicking the [Next >] button, the following screen appears:

Note
•  To change the installation destination directory, click the [Browse...]

button.
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(6) Click the [Next >] button.

>>The following screen appears:

Note
•  To change the group, enter the new group name.

(7) Click the [Next >] button.

>>The following screen appears:
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(8) Click the [Next >] button.

>>The following screen appears:

(9) Click the [Finish >] button.

>>When the installation is completed successfully, the display will return to

the Windows desktop.
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� Starting the SLP

Handling Precautions
• Before starting the SLP, quit all other applications. If you start the loader

while another application is running, the SLP may not function. Also, set
any power saver function, infrared communications and screen
saver to OFF.

• Make sure that the Decimal Symbol setting is " . " for [Control Panel] →
[Regional Settings] → [Number] command. If it has been set to some
other character, the loader cannot correctly function.

(1) Click the [Start] button at the lower portion of the screen and select

[Programs] → [SLP] → [SLP-P30(DCP31,32)] command.

>>The SLP starts and the menu window is displayed, along with handling

precautions.

(2) Click the [Next >] button.

>>The model setting method screen appears:



E9

(3) Select either method on the model setting method screen and click the [Next>]
button.

>>If [0: Set model number] is selected, the basic model screen basic model

No. will appear.

If [1: Read from DCP30] is selected, the communication range selection

screen Select will appear.

For more details, refer to the sections listed below.

When the basic model screen is displayed:

3-1 Type Setup and Environment Setup (see page E13).
When the communication range selection screen is displayed:

3-3 Communications with the DCP (see page E18).

Note
•  For details on the operating system or the mouse you are using, refer to the

user's manual provided with Windows or with your personal computer.

� Quitting the SLP
(1) Click the icon at the top right of the screen. You can also quit by selecting

[Menu] → [Quit] command.

>>The following screen appears:

(2) Click the [OK] button.
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2  -  2 Description of Functions

� SLP functions
The SLP provides the following functions for configuring DCP operation:

• Program pattern editing

• Parameter editing

• File management

• Data communications

• Model setting

The figure below shows what these functions do.

Note
• “File” refers to data for one DCP. Each file comprises the various parameter

settings and the model number information.

Functions

Program pattern editing • Creates and edits program patterns.

• Creates and edits parameters.
Parameter editing

• Saves created data to a file on a floppy disk
  or hard disk.
• Reads saved files for re-editing.

File management

Data communications
• Writes created data to the DCP.
• Reads from the DCP to the SLP.

Model setting
• Sets the model No. of the DCP to be 
  connected with the SLP.
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2  -  3 Screen Configuration

� SLP screen configuration
• Basic SLP screen

• Dialog box displayed when [Help] → [Version(A)] command is selected.

Setup items

Menu bar

Toolbar

Selection
window

Message window

Program pattern No.
Tag
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2  -  4 Menu Configuration List

Menu Icon Sub Menu 1 Sub Menu 2 Description Shortcut Keys

File New - Creates new data. [Ctrl]+[n]

Open - Opens existing data. [Ctrl]+[o]

Save - Saves the active data. [Ctrl]+[s]

Save As - Saves the active data with a new [Ctrl]+[a]
name.

- CSV Out (X) - Saves the active data in CSV -
format.

- HTML Out (H) - Saves the active data in HTML -
format.

- Quit - Quits the application. [Ctrl]+[q]
Edit - Data Check - Checks all values. -

Insert Segment New Segment Inserts a new segment. -

Segment Copy Inserts the copied segment data. -

Cut Segment (T) - Copies the selected segment data [Ctrl]+[x]
and deletes it.

Copy Segment - Copies the selected segment data. [Ctrl]+[c]

Paste Segment - Overwrites (pastes) the copied segment [Ctrl]+[v]
data onto the selected segment.

Clear (A) - Initializes the selected data. -

Copy Pattern (Y) - Copies the selected pattern data. -

Paste Pattern (S) - Overwrites (pastes) the copied pattern -
data onto the selected pattern.

Communication Read (DCP30 -> SLP) - Reads the device data. [Ctrl]+[r]

Write (SLP -> DCP30) - Writes the data to the device. [Ctrl]+[w]

Setup - Program setup (A) Program Displays the program setup. [Ctrl]+[Shift]+[a]
- Parameter setup (B) Variable parameter Displays the variable parameter. [Ctrl]+[Shift]+[b]

Variable parameter2 Displays the variable parameter 2. [Ctrl]+[Shift]+[c]
Event configuration data Displays the event configuration data. [Ctrl]+[Shift]+[d]
PID parameter Displays the PID parameter. [Ctrl]+[Shift]+[e]
PID parameter2 Displays PID parameter 2. [Ctrl]+[Shift]+[f]
Setup data Displays the setup data. [Ctrl]+[Shift]+[g]
Table data Displays the table data. [Ctrl]+[Shift]+[h]
Constant-value Displays the constant-value [Ctrl]+[Shift]+[ i ]
operation data operation data.

Option Type setup - Changes the type setup. [Ctrl]+[t]

Environment setup - Changes the environment setup. [Ctrl]+[e]

View - Pattern Graph - Displays the pattern graph. -
- Table Graph - Displays the table graph. -

Help - Version (A) - Displays the version information. -
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Chapter 3. METHODS OF OPERATION
3  -  1 Type Setup and Environment Setup

� Type setup
First, set the SLP type appropriate for the DCP model.

(1) Click the icon. This has the same result as selecting [Option] →
[Type setup] command, or pressing [Ctrl] + [t] keys.

>>The type setup dialog box appears.

(2) Select the DCP and click the [Next >] button.

>>The output type dialog box appears.
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(3) Select the output type and click the [Next >] button.

>>The option 1 dialog box appears.

(4) Select option 1 and click the [Next >] button.

>>The option 2 dialog box appears.

(5) Select option 2 and click the [ Complete] button.

Handling Precautions
•  The type setting here is for the internal use of the loader.

Be sure to set the correct DCP type.
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� Environment setup
Set the communications port and font on the personal computer.

(1) Click the icon.

Alternatively, select [Option] → [Environment setup] command, or press the

[Ctrl] + [e] keys.

>>The environment setup dialog box appears.

(2) Select the communications port.

(3) Select the font size.

(4) Click the [ OK] button.

Handling Precautions
• Normally, use "Port COM1."

Even if another communications port can be selected, it sometimes
cannot be used, depending on its configuration.
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3  -  2 File Operations

� Making new files
(1) Click the icon, select the [File] → [New] command, or press the 

[Ctrl] + [n] keys.

>>The New dialog box appears.

(2) Click [OK] button.

>>A new file opens.

� Opening existing files
(1) Click the icon, select the [File] → [Open] command, or press the 

[Ctrl] + [o] keys.

>>The open dialog box appears.

(2) Select the folder (directory) from the [Look in:] drop-down menu.

(3) Click (select) the file name.

(4) Click the [Open] button.

>>The file you selected opens.

� Overwriting and saving files
(1) Click the icon, select the [File] → [Save] command, or press the 

[Ctrl] + [s] keys.

>>The file is overwritten and saved.
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� Saving files with a new name
(1) Click the icon, select the [File] → [Save As] command, or press the

[Ctrl]+[a] keys.

>>The Save As dialog box appears.

(2) Select the folder name under the [Save in:].

(3) Enter the file name in the [File name] input box.

(4) Click the [Save] button.

>>The file is saved under the file name that you entered.

Note
•  The file is overwritten and saved if you click on (select) a file name in the

File name window.

� Outputting CSV format files
(1) Select the [File] → [CSV Out(X)] command.

>>The CSV output dialog box appears.

(2) Select the folder name under [Save in:].

(3) Enter the file name at [File name].

(4) Click the [Save] button.

>>The file is output under the file name that you entered.

Note
•  The file is overwritten and saved if you click on (select) a file name in the

File name window.

A CSV file is a text file delimited by commas, and can be used in Microsoft

Excel or other off-the-shelf spreadsheet applications.

•  When opening a CSV file using Microsoft Excel, the display format for

numerical values, time and the line, is converted into the standard Microsoft

Excel format.

� Outputting HTML format files
(1) Select the [File] → [HTML Out(H)] command.

>>The HTML output dialog box appears.

(2) Select the folder name under [Save in:].

(3) Enter the file name at [File name].

(4) Click the [Save] button.

>>The file is output under the file name that you entered.

Note
•  The file is overwritten and saved if you click on (select) a file name in the

File name window.

•  An HTML file can be used with browsers like Microsoft Internet Explorer,

like and word processors Microsoft Word.
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3  -  3 Communications with the DCP

� Communication from the DCP to the SLP (reading from the DCP)
(1) Click the icon, select the [Communication] →

[Read (DCP30 -> SLP)] command, or press the [Ctrl]+[r] keys.

>>The communication dialog box appears.

(2) Check the contents of the communication and click the [ OK] button.

>>The confirm dialog box appears.

(3) Click the [ OK] button.

>>Reading from the DCP starts.

� Communication from the SLP to the DCP (writing to the DCP)
(1) Click the icon, select the [Communication] →

[Write (SLP -> DCP30)] command, or press the [Ctrl]+[w] keys.

>>The communication dialog box appears.

(2) Check the contents of the communication and click the [ OK] button.

>>The confirm dialog box appears.

(3) Click the [ OK] button.

>>Writing to the DCP starts.

Handling Precautions
• If data settings are incorrect, an error list appears and the

communication does not start.

• If the main unit model does not match the settings in the loader, an error
message appears, showing that the settings are for the wrong model.



3  -  4 Setting up Data

� Selecting setup items

� Moving the highlighted section of the display with the keyboard
(1) Press the [↑], [↓], [←] or [→] key to move the highlighted section of the screen.

� Moving the highlighted section of the display with the mouse
(1) Click the section you want to move.

(2) Click the scroll bar to scroll the screen.

>>The screen cannot be scrolled beyond the topmost or bottommost rows on

screen.

� Changing the active window
(1) Press the [Tab] key.

>>The screen moves to the next operation window.

Note
•  Setup items are moved to according to their order on the screen.

� Entering numerical data

� Entering numerical values
The following describes how numerical values are entered:

• To enter a numerical value, press the [0] to [9] keys on the keyboard.

• To enter a hexadecimal number, press the [0] to [9] keys or the [A] to [F] keys on

the keyboard.

• To enter a decimal point, press the [.] key at the desired decimal point position.

• To enter a minus value, press the [-] key.

• To enter time data, press the [0] to [9] keys, [:] key, and [.] key on the keyboard.

Note
• To enter “2:00”, press the [2], [:], [0], and [0] keys or press the [1], [2], and

[0] keys.

• When entering time in h:min or min:s format, you cannot use the [.] key.

Likewise, when entering time in the 0.1s format, you cannot use the [:]
key.

• To correct a wrong entry, press the [Back Space] key.

>>The current displayed value is deleted.

• To cancel the currently entered numerical value, press the [Esc] key.

>>The original value is redisplayed.
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� Entering values for setup items
Use the [0] to [9] keys on the keyboard to enter values.

(1) Select the setup item to highlight it.

(2) Enter the desired value with the [0] to [9] keys.

(3) Press the [Enter] key. Pressing the [↑] or [↓] key gives the same result.

>>The value is set.

Note
• If you set the numerical value by pressing the [↑] or [↓] key, the highlighted

section moves on the screen. If you move a setup item using the mouse, the

value is not set.

• If an entered value is invalid, the original value is redisplayed. To cancel a

value midway during entry, press the [Esc] key.

� Selecting and entering data

Note
• Items that can be selected and entered are automatically displayed.

(1) Select a setup item from the drop-down menu, or press the [Tab] or [Alt]+[↓]
keys.

>>Selection Item is displayed.

(2) Click on a setup item with the mouse, or press the [↑], [↓], [←] or [→] keys, or

press the [Enter] key.

>>The value is set.

Note
• When you use the mouse, the value is set at the same time that you select it

with the mouse.

Setup item Setup item menu



3  -  5 Editing Program Patterns

� Editing segments
Before using any segment editing function, it is necessary to move the highlighted

section onto a target segment.

� Inserting a new segment
(1) Click the icon, or select the [Edit] → [Insert Segment] → [New

Segment] command.

>>The confirm dialog box appears.

(2) Click the [OK] button.

>>A new segment is inserted.

� Inserting a copied or cut segment
(1) Click the icon, or select the [Edit] → [Insert Segment] →

[Segment Copy] command.

>>The confirm dialog box appears.

(2) Click the [OK] button.

>>The copied or cut segment is inserted.

Handling Precautions
• Before inserting a copied or cut segment, it is necessary to copy or

cut the segment.  The same copied or cut segment may be inserted
any number of times.

� Cutting a segment
(1) Click the icon, select the [Edit] → [Cut Segment(T)] command, or press

the [Ctrl] + [x] keys.

>>The confirm dialog box appears.

(2) Click the [OK] button.

>>The selected segment is cut.

Handling Precautions
• Cut data is retained in the loader's memory. When using the cut

data for another segment, refer to the following descriptions:
� Inserting a copied or cut segment (see above)
� Pasting a segment (see page E22)
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� Copying a segment
(1) Click the icon, select the [Edit] → [Copy Segment] command, or press

the [Ctrl] + [c] keys.

>>The confirm dialog box appears.

(2) Click the [OK] button.

>>The selected segment is copied.

Handling Precautions
•  The copied data is retained in the loader's memory. When using the

copied data for another segment, refer to the following descriptions:
� Inserting a copied or cut segment (see page E21)
� Pasting a segment (see below)

� Pasting a segment
(1) Click the icon, select the [Edit] → [Paste Segment] command, or press

the [Ctrl] + [v] keys.

>>The confirm dialog box appears.

(2) Click the [OK] button.

>>The segment is pasted.

Handling Precautions
•  Before pasting a segment, it is necessary to copy or cut a desired

segment.

•  Pasted values overwrite any values that were previously set.

•  Copied or cut values can be pasted any number of times.

� Clearing data
(1) Click the icon, or select the [Edit] → [Clear(A)] command.

>>The confirm dialog box appears.

(2) Click the [OK] button.

>>The set values are cleared.

Note
•  The clear command is used to return the set values to their default values.

Handling Precautions
•  When "Display OFF" is selected with setup data C68 to C71, the

program items of the main unit are not displayed, but rather the
program pattern window items of the SLP-P30.
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� Copying and pasting program patterns
Before using any program-pattern editing function, it is necessary to display a

target program pattern.

� Copying a program pattern
(1) Click the icon, or select the [Edit] → [Copy Pattern(Y)] command.

>>The confirm dialog box appears.

(2) Click the [OK] button.

>>The selected program pattern is then copied.

Handling Precautions
•  The copied data is retained in the SLP-P30 memory. When using the

copied data for another program pattern, refer to the following
description:
� Pasting a program pattern (see below)

� Pasting a program pattern
(1) Click the icon, or select the [Edit] → [Paste Pattern(S)] command.

>>The confirm dialog box appears.

(2) Click the [OK] button.

>>The program pattern is pasted.

Handling Precautions
•  Before pasting a program pattern, it is necessary to copy a pattern.

When there are already values set for the program pattern, the
pasted values overwrite them. Copied pattern values can be pasted
any number of times.

� Changing tags

� Changing a tag
(1) Double-click a tag text.

>>The tag is highlighted.

(2) Enter a desired tag through the keyboard.

(3) Press the [Enter] key.

Note
•  If any illegal character is entered, the tag name is returned to the previous

tag name. Only alphanumeric characters and symbols having an ASCII code

ranging from 20 to 5FH may be used. (see table on page E24.)
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� ASCII code table

Upper 3bits

Lower 4bits

0 1 2 3 4 5 6 7
0 NUL SLE space 0 @ P ' p
1 SOH CS1 ! 1 A Q a q
2 STX DC2 “ 2 B R b r
3 ETX DC3 # 3 C S c s
4 EOT DC4 $ 4 D T d t
5 ENQ NAK % 5 E U e u
6 ACK SYN & 6 F V f v
7 BEL EIB ´ 7 G W g w
8 BS CAN ( 8 H X h x
9 HT EM ) 9 I Y i y
A LF SIB * : J Z j z
B VT ESC + ; K [ k {
C FF FS , < L \ l |
D CR GS - = M ] m }
E SO RS . > N ^ n ~
F SI US / ? O _ o DEL

The shaded part (     ) is not used.



3  -  6 Displaying Graphs

� Displaying program pattern graphs
Select [View] → [Pattern Graph] command.

>>The pattern graph of the selected program pattern is displayed.

� Displaying input line graphs
Select [View] → [Table Graph] command.

>>The line graph is displayed.

Note
•  To select an area you want to enlarge, drag the mouse from the upper left

portion to the lower right portion of the area. If you drag the mouse in the

reverse direction, the enlarged graph scale is returned to its previous size.
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3  -  7 Data Check
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� Checking the high and low limits of all data
Select [Edit] → [Data Check] command.

>>The data check begins.

� Displaying items with abnormal values
If any setting error is found through the check of high and low data limits, an error

dialog box appears and the erroneous items are listed.

(1) Click the [OK] button in the error dialog box.

(2) Double-click a setup item you want to display in the error list.  The same

operation can also be performed by selecting (highlighting) a setup item you

want to display and pressing the [Enter] key.

>>The relevant setup item is displayed.

Note
•  The format of the error list is Serial No.: Setup group name: Item name:

Line No.  Additionally, when the setup group is the program, the setup

group name is displayed as Program - Program No.
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Chapter 4. TROUBLESHOOTING
4  -  1 Error Messages

� Communications error messages

� File error messages

Category Message Description Remedy

Communication Time out. The message could not be received Check the cable connections and
error within the time limit. contacts.

An instrument other than DCP31/32 Use the loader while it is connected to
might be connected. the DCP31/32.
The main unit might not be connected.

Cannot open communications port. The communication port could not be Do not run the loader and another 
opened. application that uses the

communication port at the same time.

Communications error has A system error occurred. Try again or quit the loader and 
occurred. restart Windows.

DCP Operating through the console or Other operation is running on the After quitting the other operation,
status error CPL communication. main unit or via CPL communication. try again.

Cannot be written since the mode The main unit is not READY. Put the main unit in the READY mode
is other than the READY mode. and try again.

Data, which cannot be written, After checking the mode of the main
exists since the mode is other unit, try again.
than the READY mode.

Cannot be written according to
the status of the instrument.

Check the currently connected Currently connected instrument is not Connect the DCP31/32 and start the
instrument. the DCP31/32, or the DCP31/32 is operation.

not connected.

Cannot support currently Versions of SLP-P30 or DCP31/32 Contact Yamatake Corporation or
connected DCP31/32. are not supported. your dealer.

Category Message Description Remedy

File name This file name is not valid. An invalid file name has been Enter the correct file name.
error entered.

This file cannot be found. Make A non-existent file name has been Correctly enter the name and path of
sure that the correct path and entered, or the directory (folder) is an existing file.
file name are given. incerrect.

This file name is a reserved A file name reserved as a device Enter the correct file name.
device name. Use a different file name has been entered.
name.

Disk error Not enough free space on disk. There is not enough free space on Secure enough free space on disk.
disk.

The device is not ready. The disk is not prepared. Prepare a disk, and repeat the 
operation.

Cannot make file. The save destination might be a Save to a different destination.
CD-ROM.

File name too long. The file name is too long. Limit file names to 255 or fewer
characters.

Path name The path does not exist. An illegal path name has been Enter the correct path name, and
error Make sure that the correct path is entered. repeat the operation.

given.

File information Illegal file size. File is damaged. Damaged files cannot be used.

error Illegal file information. Recreate the file.
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� Startup error messages

Category Message Description Remedy

Loader system Can't start up two or more An attempt was made to start up Click the [OK] button.
error SLP-P30s at once. two or more SLP-P30s at once.
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