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Thank you for purchasing the MLP200
Loader Package for MPC Series Panel
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This manual contains information for
ensuring correct use of the MLP200. It
also provides necessary information for
installation, maintenance, and trou-
bleshooting.
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use the MLP200.
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REQUEST

©2004 Yamatake Corporation ALL RIGHTS RESERVED

Ensure that this User's Manual is handed over to the user before the
product is used. 

Copying or duplicating this User's Manual in part or in whole is forbid-
den. The information and specifications in this User's Manual are sub-
ject to change without notice.

Considerable effort has been made to ensure that this User's Manual is
free from inaccuracies and omissions. 
If you should find any inaccuracies or omissions, please contact
Yamatake Corporation.

In no event is Yamatake Corporation liable to anyone for any indirect,
special or consequential damages as a result of using this product.

Do not apply a strong force while connecting a loader plug. Failure to do
so might damage the instrument.

Handling Precautions
Application of excessive force to the loader plug might cause
communication failure. If such failure happens, reconnect the loader
plug correctly.

IMPORTANT



Unpacking

i

Check the following items when removing the MLP200 from its package:

1. Check the model No. to make sure that you have received the product that you ordered.

2. Check the MLP200 for any apparent physical damage.

3. Check the contents of the package against the Package List to make sure that all accessories are included

in the package.

After unpacking, handle the MLP200 and its accessories taking care to prevent damage or loss of parts.

If an inconsistency is found or the package contents are not in order, immediately contact your dealer.

Name Model No. Q'ty Remarks

System disk MLP200A100 1 CD-ROM

USB Loader cable - 1 -

User's Manual CP-UM-5355E 1 This manual.



The Role of This Manual

ii

In all, four manuals have been prepared for the MPC Series. Read the manual according to your specific

requirements.

The following lists all the manuals that accompany the MPC Series and gives a brief outline of the manual:

If you do not have the required manual, contact Yamatake Corporation or your dealer.
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MPC Series Panel Mount Mass Flow Controller
"Installation & Configurations" Manual No. CP-SP-1153E

This manual describes the hardware and all functions of this unit.
Personnel in charge of design, manufacture, operation, and/or
maintenance of a system using this unit must thoroughly read this manual.
This manual also describes the installation, wiring, all functions and
settings of this unit, operating procedures, troubleshooting, and detailed
specifications.

MPC Series Panel Mount Mass Flow Controller
Manual No. CP-UM-5317E

This manual is supplied with the product. Personnel in charge of design
and/or manufacture of a system using this unit must thoroughly read this
manual. This manual describes the safety precautions, installation, wiring
and primary specifications. For further information about operation, refer to
other manuals, "Installation & Configurations".

MPC Series Panel Mount Mass Flow Controller
"Communication Functions" Manual No. CP-SP-1154E

Those using the "communication functions" of the MPC series should read
this manual.
This manual describes an outline of communications, wiring,
communication procedures, a list of MPC series communication data, how
to remedy trouble, and communication specifications.

MLP200 Loader Package for MPC Series Panel Mount Mass Flow
Controller Manual No. CP-UM-5355E

This manual.

This manual is supplied with the MLP200 Loader Package.
The manual describes the software used to make various settings for MPC
Series using a personal computer. Personnel in charge of design or setting
of a system using MPC Series must thoroughly read this manual. The
manual describes installation of the software into a personal computer,
operation of the personal computer, various functions, and setup
procedures.



Organization of This User's Manual
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This manual is organized as follows:

Chapter 1. INTRODUCTION
Be sure to read this chapter before you start using the Loader Package.

This chapter describes the required operating environment for the personal

computer, how to install the package, and briefly introduces its features.

Chapter 2. INSTALLATION, STARTING UP AND QUITTING THE MLP
This chapter describes how to install, start up and quit.

Chapter 3. SETTING UP THE MPC
This chapter describes how to set up the data.

Chapter 4. MONITORING THE OPERATION STATUS OF THE MPC
This chapter describes how to change the settings, as well as the screens

monitoring the operation status.

Chapter 5. TROUBLESHOOTING
This chapter describes how to remedy trouble.
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Conventions Used in This Manual

v

The following conventions are used in this manual:

Handling Precautions :
Handling Precautions indicate items that the user should pay attention to
when handling the MLP200.

Note : Notes indicate useful information that the user might benefit by knowing.

: This indicates the item or page that the user is requested to refer to.

(1), (2), (3) : The numbers with the parenthesis indicate steps in a sequence or indicate
corresponding parts in an explanation.

[OK] button : Indicates a selection button in screens displayed on the personal
computer.

[Option] : Indicates messages and menus displayed on the personal computer.

[Option] → [Type Setting] :
Indicates the order to select the [Option] first and then select the 
[Type Setting] displayed on the personal computer.

>> : Indicates the result of an operation, details displayed on the personal
computer or devices, or the state of a device after an operation.

[Ctrl] key : Indicates keys on the keyboard.
[A] key

[Ctrl]+[A] key : Indicates the operation of pressing the [A] key with the [Ctrl] key on the
keyboard held down.





Chapter 1. INTRODUCTION
1  -  1 Overview

The MLP200 (simply called “MLP” from here on) is an engineering tool for MPC Series Panel Mount Mass Flow

Controller (simply called “MPC” from here on).

The MLP runs on Windows 2000/XP/Vista (simply called "Windows" from here on) on a personal computer.

Note
• Install MLP on the hard disk following the procedure in

■ Installing procedures (page 2-1).
Use the system disk that you have purchased as the backup system.

Handling Precautions
• This disk does not contain the system, and cannot be used as they are.

■ Loader functions
The MLP has the following functions:

• Setup function

• Monitor function

● Setup function
This function is for setting up parameters required for the operation of the MPC
on the personal computer and writing (setting) them to the MPC.

● Monitor function
After the setup parameters have been written to the MPC is running, switching of

modes (operating mode, instantaneous SP No. in use etc.), run state and alarm

occurrence can be checked.

The run state can also be checked on the Trend screen, and sampled data can be

output in CSV format so that it can be handled in third-party spreadsheet software

such as Microsoft Excel.

Handling Precautions
• The monitor target is limited to only one unit when the loader jack on

the (rear panel) is used for performing monitoring.

1-1



1  -  2 System Operating Environment

The following system environment is required for using the loader:

■ Hardware

■ Hardware configuration

● General configuration (connected with USB loader cable)

● Configuration with CMC10L (MPC with RS-485 communications function only)
If multiple MPC units (max. 31) with RS-485 communications are connected, the

CMC10L must be used. The CMC10L is a converter for RS-232C ↔ RS-485

conversion.

(However, if the PC has a 3-wire RS-485 communications port, the CMC10L is

not required.)

MPC

Max. 31 units

RS-232C cable

CMC10L

LOADER

CMC10

11

12

13

14

15

MLP200

Communications
USB loader Cable (Accessory)

MPC

Chapter 1. INTRODUCTION

Item Description

Personal Computer Target model PC/AT compatibles with a Pentium chip or higher

Memory 32M byte or more

Operating system Windows2000 Professional/XP Home/
XP Professional/Vista (32 bits)

USB Port 1 port or more (Use USB loader cable)

Serial port 9-pin, serial port, 1ch or more (Use CML10L)

Peripheral Devices Display 800 X 600 dot or more, 1024 X 768 dot or more,
16 bit color or more

Hard disk drive Hard disk with at least 40M byte of free space

CD-ROM drive 1 drive or more

Pointing device Windows-compatible mouse or equivalent device

1-2
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Note
• Personal computer used for confirmation of operating environment

Chapter 1. INTRODUCTION

Manufacturer Model No.

Dell OptiPlex GX270

IBM ThinkPad A31





Chapter 2. INSTALLATION, STARTING UP AND QUITTING THE MLP
2  -  1 MLP Installation

■ MLP installation procedures
The MLP is installed on the hard disk of a personal computer. After installation,

keep the system disk that you have purchased as a backup.

This section describes how to install the MLP on a personal computer.

Handling Precautions
• Since the CD-ROM does not include an operating system for a personal

computer, the program cannot be used on a personal computer which
does not have an OS.

• If you start up the Installer while another application is running, the
Installer may malfunction.
Remove other resident applications from their directories before starting
up the Installer. The MLP sometimes cannot be started up depending on
the combination of other applications and drivers. For details on
Windows and personal computer settings, refer to the User's Manuals
provided with Windows and the personal computer.

The following descriptions and sample screens are based on a personal computer

with Windows XP as the OS. 

(1) Set the CD-ROM in the CD-ROM drive of your personal computer.

>>The installation program starts automatically, and the USB/MLP selection

screen appears.

(2) Click [Install MLP] button.

>>The following screen appears:

2-1
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(3) Click [Next >] button.

>>The following screen appears :

(4) If you agree to the software license agreement and wish to install the loader,

click the [Agree >] button.

If you abort the installation, click the [Don’t agree] button.

>>When clicking the [Agree >] button, the following screen appears :

(5) Enter a registered user name and company name, and then click the [Next >]
button.

>>The following screen appears :

Chapter 2. INSTALLATION, STARTING UP AND QUITTING THE MLP



(6) Click [Next >] button.

>>The following screen appears :

Note
•  To change the installation destination directory, click [Browse...] button.

(7) Click [Next >] button.

>>The following screen appears :

Note
•  Check the necessary files. To display a PDF file, Adobe Reader is required.

If Adobe Reader is not already installed on your PC, download it from the

Adobe Systems webpage. 

Chapter 2. INSTALLATION, STARTING UP AND QUITTING THE MLP
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(8) Check on (put a check mark : ) software components you wish to install and

click [Next >] button.

>>The following screen appears :

Note
•  To change the program folder, enter the new folder name.

(9) Click [Next >] button.

>>The following screen appears :

Chapter 2. INSTALLATION, STARTING UP AND QUITTING THE MLP
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(10)Click [Next >] button.

>>The following screen appears :

(11)Click [Finish >] button.

>>When the installation is completed successfully, the screen will return to

the Windows screen.

Chapter 2. INSTALLATION, STARTING UP AND QUITTING THE MLP



A device driver must be installed before using the USB loader cable.

Follow the procedure below to install the device driver.

■ Installing the device driver

Handling Precautions
• Be sure to follow the procedure below when installing the device driver.

The USB cable may not be recognized if the procedure is not followed. If
the cable is not recognized, uninstall the driver and then install it again.

• Administrator privileges on the computer are required for driver installa-
tion. Installation should be done by the administrator or by a user who
belongs to the administrator group. The USB loader cable is supported
on Windows 2000/XP/Vista (32 bit type). It is not supported on 64-bit
Windows XP, or on Windows 95, Windows NT, MS-DOS or PC-DOS.

• If there are multiple USB ports, connect the USB loader cable to the
same port every time. If it is connected to a different port, there is a
chance that driver installation may be required again.

1. Put the MLP CD-ROM into the CD-ROM drive of the personal computer.
>>The installation program is then started up automatically and the following

screen appears:

(1) Click the [Install USB loader cable driver] button.

>> The following screen appears:

2 -  2 Installing the USB Loader Cable Device Driver

Chapter 2. INSTALLATION, STARTING UP AND QUITTING THE MLP
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(2) Click the [Next >] button.

>> The following screen appears:

(3) Select [AGREE] and click the [Next>] button.

>>The following screen appears :
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(4) Click the [Continue Anyway] button.

>>The installation program then starts up, and after it is completed, the follow-

ing screen appears:

(5) Click [Finish] button to complete the installation.

2. Insert the USB loader cable into the USB port.
>>When Windows recognizes the USB cable, the notification shown below

appears on the task tray and the driver installation wizard appears.

3. Install the device driver.
(1) Usually, when Windows recognizes the USB loader cable, the window shown

below appears. (In some cases, depending on the Windows environment, it may

not appear.) Select [No, not this time] and click the [Next >] button.
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(2) For the retrieval location of the device driver to be installed, select the [Install
the software automatically (Recommended)] and click the [Next >] button.

>>Retrieval of the device driver starts.

>>When the device driver is found, the following window appears:

Chapter 2. INSTALLATION, STARTING UP AND QUITTING THE MLP
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(3) Click [Continue Anyway].
>>Installation of the device driver starts

>>When the device driver installation is complete, the following window

appears:

(4) Click [Finish].
>>When the installation is complete, the notification shown below appears on

the task tray, and Windows now correctly recognizes the USB loader cable.
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(5) Select [Control Panel] → [System] → [Hardware] → [Device Manager] (for

Windows XP/2000), and find the port number for the Yamatake USB Loader

Comm. from [Ports (COM & LPT)].

(6) Start the MLP, select [Menu] → [Option], and set to the communications port

number obtained in the previous step. Then press the [OK] button to complete

the configuration.

Note
• When the [USB loader cable auto select] button is clicked, port selection

can be done automatically .

Note
• If the MLP loader CD-ROM is not available, execute drvsetup.exe on the

computer on which the MLP is installed. The setup program is normally

installed in C:\Program Files\MLP\MLP200. Then install the device driver.
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■ Uninstalling the device driver

Handling Precautions
• Removing the driver requires restarting the computer. Close other

applications first, and then uninstall the driver.

• To uninstall the driver, administrator rights are required on the computer.
Uninstalling should be done by the administrator or by a user who
belongs to the administrator group.

1. Execute the driver removal program.
(1) Go to [Control Panel] → [Add or Remove Programs] and click on

[Windows Driver Package - Yamatake (YC slp) USB (04/19/2007
1.0.0)]. Click the [Change/Remove] button. 

(2) Click the [Yes] button.

(3) Restart the computer.
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2 -  3 Starting up and Quitting the MLP

2-13

■ Starting up the MLP
Double-click the MLP200A100 icon on the desk top or click [Start] button

at the lower portion of the screen and select [Programs] → [MLP] →
[MLP200A100].
>>The MLP is started up and the menu window is displayed.

Note
•  For the operating system details and the mouse setup, refer to User’s

Manuals provided with Windows.

■ Quitting the MLP
Click icon at the top right of the screen.

The operation is the same by selecting the [Menu] → [Quit].
>>The MLP is completed.
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Chapter 3. SETTING UP THE MPC
3  -  1 Setup Function

■ Overview
The setup function allows you to set the various parameters (about 10 to 50

constants required for operation) and write these parameters to the MPC so that it

functions according to your particular control requirements.

When the MPC is used for the first time, it will not function as required unless it is

set up by using this setup function.

Parameters such as SP (set point) and control constants that are changed relatively

frequently while the MPC is running can also be set from the monitor function

screen.

By the setup function, parameters that hardly need changing later once they are set

are saved to file in list format before the MPC is run, and the saved file is called

up and written to the MPC in a single operation.

■ Screen explanations

● Menu screen

• Menu configuration list

3-1

Menu Icon Sub Menu Description Shortcut Keys

Menu Setup Displays the Setup window. Ctrl+S

Monitor Displays the Monitor / Trend Ctrl+M
window.

- Option(E) Changes the environment setup. Ctrl+E

- Quit Quits the application. Ctrl+Q

Help - Version(A) Displays the version information. Ctrl+A



3-2

● Setup screen

Message window

Menu bar
Tool bar

Parameter display
area       

Selection
window

Chapter 3. SETTING UP THE PARAMETERS OF THE MPC
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• Menu configuration list

Chapter 3. SETTING UP THE PARAMETERS OF THE MPC

Menu Icon Sub Menu Description Shortcut Keys

File New Creates new data. Ctrl+N

Open Opens existing data. Ctrl+O

Save Saves the active data. Ctrl+S

- Save As Saves the active data with Ctrl+A
name.

- CSV Out(X) Saves the active data in CSV Ctrl+X
format.

- HTML Out(H) Saves the active data in HTML Ctrl+H
format.

- Print Prints out the data. -
(Same contents of data saved
in the HTML format.)

- Quit Quits the application. Ctrl+Q
Edit - Data Check Checks all setting values. Ctrl+D
Display - Parameter disp area Displays the parameter display -

area.
- Hint enable Displays the hint. -
- Auto size Makes the auto-cell size -

enabled.
- Size initalize Initializes the cell size. -
- Cell size adjust Makes the cell size matched -

with the window.

Communication Read(MPC Series -> MLP) Reads the device data. Ctrl+R
(R)
Write(MLP -> MPC Series) Writes the data to the device. Ctrl+W
(W)

Setup - Setup Instantaneous Displays or sets the setup flowrate. Shift+Ctrl+A
data flowrate(A)

Function setup(B) Displays or sets the function setup. Shift+Ctrl+B
Parameter setup Displays or sets the parameter setup. Shift+Ctrl+C
(C)
Device Displays the device related data. Shift+Ctrl+D
Information(D)

Option Type Setting Changes the type setup. Ctrl+T

Environment Setting Changes the environment setup. Ctrl+E

Help - Version(A) - -



3  -  2 Method of Setup

3-4

Configure setup in offline state (without connecting the cable to MPC).

Click the [Option] on the menu screen.  Set up in the following steps:

The following tasks are performed:

Step 1: Setting up the loader type

Step 2: Initialization (clearing previous setting values)

Step 3: Setting up the environment

Step 4: Setting up MPC parameters

Step 5: Saving setup data

Step 6: Downloading the setup

Handling Precautions
• Operations in steps 1 to 5 are required before the setup parameters

are entered on the MPC. Be sure to perform these steps. Otherwise,
the MPC may be set up incorrectly. For example, the required setup
items may not be displayed or unrequired items may be displayed.

• Step 6: Connect your personal computer to the MCP with the cable
before downloading.

● Step 1 (setting up the loader type)
Set up the loader type to match the MPC model number.

Note
• When the [Read] button is clicked under the condition that the cable is

connected to the MPC, the data is read out from the MPC. By this operation,

the downloading of the incorrect parameters caused by model number setup

error can be avoided.

(1) Click icon.

The operation is the same by selecting the [Option] → [Type Setting] or the

[Ctrl] + [T] keys.

>>The Type Setting dialog box is displayed.

(2) Set the Control flow range and Option.

(3) Select from the selection items for each setting item.

(4) Click [OK] button.

Handling Precautions
• "Type" set here is the setting for internal use on the loader. The

model number of the MPC will not change even if the type is changed
on the loader.

• For an explanation of each of the specifications, refer to;
MPC Series Panel Mount Mass Flow Controller User's Manual

"Installation & Configurations" CP-SP-1153E.

Chapter 3. SETTING UP THE PARAMETERS OF THE MPC
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● Step 2 (initialization)
(1) Click icon.

The operation is the same by selecting the [File] → [New] or the [Ctrl] + [N]
keys.

>>The initialize dialog box appears.

(2) Click [OK] button.

>>A new file opens.

Handling Precautions
• If the MPC is a special model (not a standard model), do not initialize.

• For instructions on initializing a special model, contact Yamatake
Corporation.

● Step 3 (setting up the environment)
Set the communications port and font on the personal computer.

(1) Click icon.

The operation is the same by selecting the [Option] → [Environment Setting]
or [Ctrl] + [E] keys.

>>The Environment Setting dialog box appears.

(2) Set the communications port.  Select the port from the selection items.

(3) Set the font size. Select the front size from the selection items.

(4) Click [OK] button.

Handling Precautions
• When the [USB loader cable auto select] button is clicked, port selec-

tion can be done automatically.

• Normally “0: Loader Cable” should be selected for “Loader cable/RS-
485.” 
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● Step 4 (Setting up MPC parameters)
The following setup is required for running the MPC.

• Instantaneous flowrate

• Function setup

• Parameter setup

• Device information (Read only and cannot be changed)

Note
• For details on the functions, refer to;

MPC Series Panel Mount Mass Flow Controller User's Manual
"Installation & Configurations" CP-SP-1153E.

Move the cursor to the target channel of each setup item, and perform the

following operations:

• When the setting is a numerical value
Enter the numerical value, and press [Return] key.

• When the setting is selected by a number
Press the right mouse button on a setting item.  The list of settings you can select

will appear.  Select a desired item to complete the setting.

Handling Precautions
• About connection to the personal computer

Normally, the MPC is connected to the personal computer with the
special cable.
Select [Option] → [Type Setting] and set [Loader cable/RS-485] to
[RS-485].  The controller is then connected through the CMC10L.
At this time, the environment setting and communication setup on the
MPC main unit must be adjusted beforehand.
Additionally, configure the settings on the MPC in the offline mode
(the cable is not connected to the MPC).  For details, refer to;

MPC Series Panel Mount Mass Flow Controller User's Manual
"Communication Functions" CP-SP-1154E.

● Step 5 (saving setup data)
When you have finished making the settings, save the setup.

Saving setups in advance and using saved setups greatly reduces the time and load

when setting up the loader. The following items are saved:

• Type

• Setup parameters

(1) The operation is the same by selecting the [File] → [Save As] or  [Ctrl] + [A]
keys.

>>The Save As dialog box appears.
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(2) Enter the file name, and click [Save] button.

● Step 6 (downloading the setup)
Write the set parameters or parameters called up from a saved file to the MPC.

(1) Use the special loader cable to connect the personal computer to the MPC
body.

(2) Turn the MPC ON.

(3) Click icon.

The operation is the same by selecting [Communication] →
[Write(MLP→MPC Series)] in the pull-down menu.

>>The message "Writing is going to be executed." is displayed.

(4) Click [OK] button.

>>This starts writing of the setup parameters.

During writing, the message [Please wait.] is displayed. When writing

ends, the message [Normal end] is displayed.

Handling Precautions
• If writing fails, the message [Communications error has occurred.] is

displayed. If writing is not possible, refer to;
Chapter 5. TROUBLESHOOTING.
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Chapter 4. MONITORING THE MPC OPERATING STATUS
4  -  1 Monitoring Function

■ Overview
To enter the monitor screens, click [Monitor] in the menu screen.

There are two screens of “Numeric monitor” and “Trend monitor” for the monitor.

Each screen can be selected by the menu bar of the screen.

• Numeric Monitor screen:
This screen is for performing operations such as monitoring operating status,

changing setups or switching modes.

• Numeric display of the various operating parameters

(parameters can be changed)

• Lamp indication of operating status of the various running modes

(lamp indications can be operated)

• Alarm display (representative and detailed)

• Trend Monitor screen:
This screen is for monitoring the running state of the MPC in the form of a trend

graph.

• The screen displays graphs showing the trends in SP value, PV value and valve

drive output.

(If the personal computer is connected by RS-485 communications, trends for

up to 5 units can be displayed.)

• Screen display of digital data trends for max. of six data items

• Export of sampled data as CSV file

• Trend screen dumps

• Sampling cycle

Variable within the range 1 to 3600s

• Max. sampling count

60,000 (fixed regardless of number of data items to sample)

Note
•  A "CSV file" is the data format that can be handled in third-party

spreadsheet software such as Microsoft Excel. In this format, sampled trend

data can be interpreted in spreadsheet software.

These screens can be used to perform the following operations:

• Monitoring of operating status and changing of parameters in the Numeric

Monitor screen

• Switching of the operation mode in the Numeric Monitor screen

• Monitoring of trends and sampling of data while the MPC is operating

• Monitoring of alarm states in the Numeric Monitor screen

Handling Precautions
• About connection to the personal computer

When making the setup or operating the monitor using the loader,
connect the loader cable.

4-1
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• Before starting the trend monitor, configure the settings suitable for the
trend monitor.

• The sampling cycle sometimes shifts due to fluctuations in the
communications cycle.  To perform measurement at exact times, use
the special recorder or data logger.

■ Screen explanations

● Numeric monitor screen

• Menu configuration list

Chapter 4. MONITORING THE MPC OPERATING STATUS

Menu Icon Sub Menu Description Shortcut Keys

File - Quit Quits the Monitor window. Ctrl+Q

Numeric Numeric Monitor Starts/stops the monitor. Ctrl+M
Monitor (M) Start/Stop (M)

Option (O) - Reset integrated Resets the integrated flowrate. -
flowrate

Alarm (A) Displays the Alarm Details window. -

Command Line (C) Displays the Command Line -
window.

Trend - - Changes the display to the trend -
Monitor (T) monitor.

Help - Version(A) Displays the version information. -
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● Trend monitor screen

• Menu configuration list

• Operating status display
The table below shows the relationship between the numerical value displayed

at the bottom of the screen and the operating status.

Chapter 4. MONITORING THE MPC OPERATING STATUS

Menu Icon Sub Menu Description Shortcut Keys

File - Quit Quits the Monitor window. Ctrl+Q

Trend Trend monitor Starts/stops the trend monitor. Ctrl+T
monitor Start/Stop (T)

CSV Read Reads the trend data in CSV -
format.

CSV Out(X) Outputs the trend data in CSV Ctrl+X
format.

Clipboard Graph Outputs an image of the graph to Ctrl+C
Out the Clipboard.

Option Setup Displays the Setup window. -

Numeric - - Changes the display to the -
Monitor numeric monitor

Help - Version(A) Displays the version information. -

Numeric display Status
Alarm 0 No alarm

1 Alarm occurrence
OK lamp 0 Lamp OFF

1 Lamp ON
EV1, EV2 0 OFF

1 ON
DI1 to DI2 0 OFF

1 ON
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• Icon list

• Zooming the graph

Drag the mouse from the upper left portion to the lower right portion with the left

mouse button kept pressed.

• Canceling the zoomed graph

Drag the mouse from the lower right portion to the upper left portion with the left

mouse button kept pressed.

Chapter 4. MONITORING THE MPC OPERATING STATUS

Icon Description

Returns the graph to the start time.

Returns the graph by 1/2 screen.

Returns the graph by 1/4 screen.

Advances the graph by 1/4 screen.

Advances the graph by 1/2 screen.

Advances the graph to the latest time.

Zooms out the graph.

Undoes the graph zoom.

Zooms in the graph.

Specify a time scale of the graph.
1min.
2min.
10min.
1hr.
12hrs.
24hrs.
Auto



4  -  2 Method of Operation

■ How to operate the numeric monitor screen

● Start of monitoring (start of communications)
The operation described below is required to start monitoring.

Otherwise, monitoring and rewriting of data cannot be performed.

• Click icon.

The operation is the same by selecting [Numeric Monitor] → [Numeric Monitor
Start].
>> During normal operation: The data on the MPC is displayed.

During an error: The message [Check the device to which the
loader is connected.] is displayed.  Remedy

according to Chapter 5. TROUBLESHOOTING.

The following operations are possible when the device and the loader are correctly

connected:

● Monitoring of operation state and changing of parameters

● Changing of data
The procedure described below is required to change data.
(1) Move the pointer to the data to be changed, and double-click the left button of

the mouse (pressing the [Enter] key gives the same result).
>>The dialog box for data change is displayed.

(2) After changing the data, click the [OK] button.
>>The data is updated.

• Changeable data
• Operation mode
• Instantaneous SP No. in use
• Setting flowrate(SP-0 to SP-3)

4-5
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Operation mode 0 : Valve fully closed
1 : Valve control
2 : Valve fully open

Numeric monitor Instantaneous SP No. in use
(displayed in table format) Instantaneous SP value in use
Numeric group monitor PV value (control flowrate)

Valve drive output
Setting flowrate SP-0
Setting flowrate SP-1
Setting flowrate SP-2
Setting flowrate SP-3
Integrated event setting flowrate
Integrated flowrate

State monitor Alarm
(displayed in lamp lighting Event
format) External switch

OK ramp
Slow start operation
Digital/analog setting
Integrated count status
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Handling Precautions
• Data change is not possible when the Numeric Monitor display is

stopped. 

• Depending on the function settings, a data change may not be made
even if the data change procedure is followed. For details, refer to: 

MPC Series Panel Mount Mass Flow Controller User's Manual
"Installation & Configurations" CP-SP-1153E.

● Use of the command line
Data can be read or written or the mode switched by directly entering

communications commands on the command line.

Handling Precautions
• Use of the command line is not generally required, and sending an

erroneous command can cause problems. For instructions on setting
the command type, address, data, etc., contact Yamatake
Corporation.

• For details on communications commands and data addresses,
refer to;

MPC Series Panel Mount Mass Flow Controller User's Manual
"Installation & Configurations" CP-SP-1153E.

● Checking details of alarms
You can check the details of alarms in the Alarm window when an alarm occurs.

• Click icon.

The operation is the same by selecting the [Option (O)] → [Alarm (A)].
• The details of the alarm that is occurring are displayed.

Handling Precautions
• This window displays the details of currently occurring alarms, and

does not have a function for restoring the MPC. To restore the MPC,
you must perform the appropriate remedy described in MPC Series
Panel Mount Mass Flow Controller User's Manual "Installation &
Configurations" CP-SP-1153E.

Chapter 4. MONITORING THE MPC OPERATING STATUS
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■ How to operate the trend monitor

● Setup
Select [Graph setup], [Station address setup], [Trend monitor color setup],
and [Trend trigger setup] at [Option (O)] → [Setup], and make the settings

below for each sampled data.

As the cycle and display upper/lower limits are common to all channels.

• Graph setup (left axis is flow rate, right axis is valve amperage)

Handling Precautions
• Be sure to change the sampling cycle setting only when trend monitor-

ing is stopped. 

• Station address setup (only for RS-485 communications)

Handling Precautions
• Can be set only if [1: RS-485] is selected for [Loader cable/RS-485] at

step 3 (Setting up the environment) on page 3-5.

Chapter 4. MONITORING THE MPC OPERATING STATUS

Setting Item Description Setting Range Factory Setting

Cycle Setting of sampling cycle 1 to 3600s 1

Display low limit Lower value of left vertical -1999 to display upper 0
of left axis axis of screen display limit

Display high limit Upper value of left vertical Display lower limit to 20
of left axis axis of screen display 9999

Display low limit Lower value of right vertical -1999 to display upper -10
of right axis axis of screen display limit

Display high limit Upper value of right vertical Display lower limit to 110
of right axis axis of screen display 9999

Setting Item Description Setting Range Factory Setting

Station adress Sets the station address to 0 : Not used 1
which the data is transmitted. 1 to 127 :Station adress

Station - Fixed 0 0
sub adress
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• Selecting trend monitor colors

When each button is selected, the color selection screen will appear.

Select a desired color.

Clicking [Default] will return the color setting to its initial value.

• Setting up the trend trigger

When setting up the trend triggers, the trend can be started and stopped according

to the status of the numeric monitor.

The trend trigger setup is valid only while the numeric monitor is running.

When setting up the trend save triggers, the trend can be saved according to the

status of the numeric monitor.

The file is saved into a specified trend save folder in the "TREND-YYYY-MM-

DD-HH-MM-SS.CSV" format.

Chapter 4. MONITORING THE MPC OPERATING STATUS
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● Starting the data sampling
When the setup is completed, start up the trend monitor.

Click icon.

The same operation can be started by selecting [Trend Monitor] → [Trend
Monitor Start].
The data sampling is started, and then the trend of the specified parameters is

displayed on the screen.

• Once the trend monitor is started, it continues until the stop operation is

performed or the data for 60,000 cycles is sampled.

• If the stop operation is not performed, the data is overwritten onto the old data

when the data sampling for 60,000 cycles is completed.

• The screen can be transited to the "Numeric Monitor" screen while the trend

monitor is running.  However, the loader cannot be quitted or the screen cannot

be transited to the "Setup" screen.  To do so, quit the trend monitor.

Note
• If the check mark " " on the left of the item at the bottom of screen is

removed, the graph for that item is not displayed.

● Stopping the data sampling
Select [Trend Monitor] → [Trend Monitor Stop].
The trend monitor is then stopped.

● Saving sampled data
The data sampled using the trend monitor can be saved into a file in the CSV

format.  The sampled data saved in the CSV format can be processed using

spreadsheet applications, such as Microsoft Excel.

Handling Precautions
• The data can be saved into a file even while the trend monitor is

running.

• Save the sampled data before trend start or CSV data read. After
trend start or CSV data read is executed, the sampled data is
overwritten.

● Saving clipboard graph output
Contents displayed on the Trend Monitor, such as SP value, PV value and valve

amperage, can be directly saved to the clipboard in the form of a screenshot.
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Chapter 5. TROUBLESHOOTING
5  -  1 Error Messages and Remedy

■ Setup error messages

■ Communications error messages

5-1

Category Message Description Remedy

Communication Time out. The message cannot be received Check the cable connections and
error within a period of the time-out time. contacts.

An instrument other than MPC is Use the loader with it connected to
connected. MPC.
The main unit is not connected.

Cannot open communications port. The communication port cannot be Do not run the loader and other 
opened. application using the communication 

port at the same time.

A communications error has The system error occurs. Re-operate or quit the loader to
occurred. or restart Windows.

Check the connected Inconsistency occurs on the Check the communication setup.
instrument. communication setup.

Trend monitor is active. The monitor screen cannot be quitted Quit the monitor screen after the 
while the trend monitor is running. trend monitor has been completed.

MPC Cannot support currently The loader currently in use is not Contact Yamatake Corporation or
status error connected MPC. applicable to the version of the main its dealer.

unit.

Flow range or gas type Mismatch of model numbers. Click [Read model] on the 
mismatch between MPC and model selection screen to read 
loader. Upload stopped. out the MPC model No.

Parameter settings exceeded Attempt to write data outside the After reading out the data from 
range. Some data possibly not allowable range. the MPC, review the
written. parameter settings.

Category Message Description Remedy

Loader system Can't start up three or more MLP Three or more loaders are started Click [OK] button.
error 200s at once. at the same time.
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■ File error messages

Category Message Description Remedy

File name This filename is not valid. An invalid file name is input. Input a correct file name.
error

This file cannot be found. A file name not existing is input. Input an existing file name.
Make sure that the correct path
and filename are given.

This filename is a reserved A file name reserved for the device Input a correct file name.
device name. name is input.
Use a different filename.

Disk error Not enough free space on disk. The disk free capacity is insufficient. Keep a sufficient disk free capacity.

The device is not ready. The disk is not ready. Prepare the disk and restart the 
operation.

Cannot make file. The CD-ROM is specified as save Save the file to another directory.
destination.

File name too long. The file name is too long. Use 255 characters or less for the
file name.

Pass name The path does not exist. An illegal path name is input. Input a correct path name and 
error Make sure that the correct path is restart the operation.

given.

File information Illegal file size. The file is corrupted. Corrupted file cannot be used.

error Illegal file information. Create a file again.



Note
• "." (period) should be set as the decimal separating symbol in the Windows con-

trol panel.

Example: for Windows XP, go to [Control Panel] → [Date, Time, Language,
and Regional Options] → [Regional and Language Options] → [Regional
Options] → [Customize...] → [Decimal symbol]. Select " . " and click [OK]
button.

5-3

Chapter 5. TROUBLESHOOTING

Trouble Description Remedy

Numeric values are not displayed If a decimal point symbol other than " . " (period) Check that the decimal point symbol
correctly. is set, the loader does not function correctly. is " . " (period).  If not, set the decimal

point symbol to " . " (period).

5  -  2 Other Troubleshooting
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Terms and Conditions
We would like to express our appreciation for your purchase and use of Yamatake products.
You are required to acknowledge and agree upon the following terms and conditions for your purchase of Yamatake
products (field instruments, control valves, and control products), unless otherwise stated in any separate document,
including, without limitation, estimation sheets, written agreements, catalogs, specifications and instruction manuals.

1. Warranty period and warranty scope
1.1 Warranty period

Yamatake products shall be warranted for one (1) year from the date of your purchase of the said products or the
delivery of the said products to a place designated by you.

1.2 Warranty scope
In the event that Yamatake product has any failure attributable to Yamatake during the aforementioned warranty
period, Yamatake shall, without charge, deliver a replacement for the said product to the place where you
purchased, or repair the said product and deliver it to the aforementioned place.
Notwithstanding the foregoing, any failure falling under one of the following shall not be covered under this
warranty:

(1) Failure caused by your improper use of Yamatake product
(noncompliance with conditions, environment of use, precautions, etc. set forth in catalogs, specifications,
instruction manuals, etc.);

(2) Failure caused for other reasons than Yamatake product;
(3) Failure caused by any modification or repair made by any person other than Yamatake or Yamatake's

subcontractors;
(4) Failure caused by your use of Yamatake product in a manner not conforming to the intended usage of that

product;
(5) Failure that the state-of-the-art at the time of Yamatake's shipment did not allow Yamatake to predict; or
(6) Failure that arose from any reason not attributable to Yamatake, including, without limitation, acts of God,

disasters, and actions taken by a third party.
Please note that the term "warranty" as used herein refers to equipment-only-warranty, and Yamatake shall not
be liable for any damages, including direct, indirect, special, incidental or consequential damages in connection
with or arising out of Yamatake products.

2. Ascertainment of suitability
You are required to ascertain the suitability of Yamatake product in case of your use of the same with your
machinery, equipment, etc. (hereinafter referred to as "Equipment") on your own responsibility, taking the
following matters into consideration:

(1) Regulations and standards or laws that your Equipment is to comply with.
(2) Examples of application described in any documents provided by Yamatake are for your reference

purpose only, and you are required to check the functions and safety of your Equipment prior to your use.
(3) Measures to be taken to secure the required level of the reliability and safety of your Equipment in your use

Although Yamatake is constantly making efforts to improve the quality and reliability of Yamatake
products, there exists a possibil i ty that parts and machinery may break down.
You are required to provide your Equipment with fool-proof design, fail-safe design, anti-flame
propagation design, safety design, or the like so that the said Equipment may satisfy the level of the
reliability and safety required in your use, whereby preventing any occurrence of physical injuries, fires,
significant damage, and so forth.

3. Precautions and restrictions on application
Yamatake products other than those explicitly specified as applicable (e.g. Yamatake Limit Switch For Nuclear
Energy) shall not be used in a nuclear energy controlled area (radiation controlled area).
Any Yamatake products shall not be used for/with medical equipment.
In addition,
you are required to conduct a consultation with our sales representative and understand detail specifications,
cautions for operation, and so forth by reference to catalogs, specifications, instruction manual , etc. in case that
you intend to use Yamatake product for any purposes specified in (1) through (6) below.
Moreover, you are required to provide your Equipment with fool-proof design, fail-safe design, anti-flame
propagation design and other designs of protection/safety circuit on your own responsibility to ensure the
reliability and safety, whereby preventing problems caused by failure or nonconformity.

(1) For use under such conditions or in such environments as not stated in technical documents, including
catalogs, specification, and instruction manuals

(2) For use of specific purposes, such as:
* Nuclear energy/radiation related facilities

[For use outside nuclear energy controlled areas] [For use of Yamatake Limit Switch For Nuclear Energy]
* Machinery or equipment for space/sea bottom
* Transportation equipment

[Railway, aircraft, vessels, vehicle equipment, etc.]
* Antidisaster/crime-prevention equipment
* Burning appliances
* Electrothermal equipment
* Amusement facilities

(3) Supply systems such as electricity/gas/water supply systems, large-scale communication systems, and
traffic/air traffic control systems requiring high reliability

(4) Facilities that are to comply with regulations of governmental/public agencies or specific industries
(5) Machinery or equipment that may affect human lives, human bodies or properties
(6) Other machinery or equipment equivalent to those set forth in items (1) to (5) above which require high

reliability and safety



4. Precautions against long-term use
Use of Yamatake products, including switches, which contain electronic components, over a prolonged period may
degrade insulation or increase contact-resistance and may result in heat generation or any other similar problem
causing such product or switch to develop safety hazards such as smoking, ignition, and electrification.
Although acceleration of the above situation varies depending on the conditions or environment of use of the
products, you are required not to use any Yamatake products for a period exceeding ten (10) years unless
otherwise stated in specifications or instruction manuals.

5. Recommendation for renewal
Mechanical components, such as relays and switches, used for Yamatake products will reach the end of their life
due to wear by repetitious open/close operations.
In addition, electronic components such as electrolytic capacitors will reach the end of their life due to aged
deterioration based on the conditions or environment in which such electronic components are used.
Although acceleration of the above situation varies depending on the conditions or environment of use, the
number of open/close operations of relays, etc.
as prescribed in specifications or instruction manuals, or depending on the design margin of your machine or
equipment, you are required to renew any Yamatake products every 5 to 10 years unless otherwise specified in
specifications or instruction manuals.
Field instruments (sensors such as pressure/flow/level sensors, regulating valves, etc.) will reach the end of their
life due to aged deterioration of parts.
For those parts that will reach the end of their life due to aged deterioration, recommended replacement cycles are
prescribed. You are required to replace parts based on such recommended replacement cycles.

6. Other precautions
Prior to your use of Yamatake products, you are required to understand and comply with specifications (e.g.,
conditions and environment of use), precautions, warnings/cautions/notices as set forth in the technical documents
prepared for individual Yamatake products, such as catalogs, specifications, and instruction manuals to ensure the
quality, reliability, and safety of those products.

7. Changes to specifications
Please note that the descriptions contained in any documents provided by Yamatake are subject to change
without notice for improvement or for any other reason.
For inquires or information on specifications as you may need to check, please contact our branch offices or sales
offices, or your local sales agents.

8. Discontinuance of the supply of products/parts
Please note that the production of any Yamatake product may be discontinued without notice.
For repairable products, we will, in principle, undertake repairs for five (5) years after the discontinuance of those
products. In some cases, however, we cannot undertake such repairs for reasons, such as the absence of repair
parts.
For field instruments, we may not be able to undertake parts replacement for similar reasons.



Specifications are subject to change without notice. (08)

Advanced Automation Company

1-12-2 Kawana, Fujisawa
Kanagawa 251-8522 Japan

URL: http://www.azbil.com 1st Edition: Issued in June 2004 (W)
2nd Edition: Issued in May 2009 (G)


	The Role of This Manual
	Contents
	Chapter 1. INTRODUCTION
	1 - 1 Overview
	1 - 2 System Operating Environment

	Chapter 2. INSTALLATION, STARTING UP AND QUITTING THE MLP
	2 - 1 MLP Installation
	2 - 2 Installing the USB Loader Cable Device Driver
	2 - 3 Starting up and Quitting the MLP

	Chapter 3. SETTING UP THE MPC
	3 - 1 Setup Function
	3 - 2 Method of Setup

	Chapter 4. MONITORING THE MPC OPERATING STATUS
	4 - 1 Monitoring Function
	4 - 2 Method of Operation

	Chapter 5. TROUBLESHOOTING
	5 - 1 Error Messages and Remedy
	5 - 2 Other Troubleshooting

	Terms and Conditions

